summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-09-10 01:03:01 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-09-10 01:03:01 +0000
commit0112301ebe0f904abe72b12bbf2590dc59e74dec (patch)
treefac6e2dcf8cd0a0f8bf31f49ff46c5f7488b8d90 /dev-lisp/cl-tbnl
parentMinor fix (diff)
downloadhistorical-0112301ebe0f904abe72b12bbf2590dc59e74dec.tar.gz
historical-0112301ebe0f904abe72b12bbf2590dc59e74dec.tar.bz2
historical-0112301ebe0f904abe72b12bbf2590dc59e74dec.zip
New upstream version.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest12
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.6.1.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.6.11
4 files changed, 53 insertions, 6 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 47b93a7f1c9c..dc2be54c9413 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.11 2005/08/04 17:41:36 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.12 2005/09/10 01:03:01 mkennedy Exp $
+
+*cl-tbnl-0.6.1 (10 Sep 2005)
+
+ 10 Sep 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.6.1.ebuild:
+ New upstream version.
04 Aug 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-tbnl-0.5.5.ebuild:
Add standalone USE flag.
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index 5179c25d0ddb..9ce4e0da6d1e 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1be6e7b0d70e74a912e46d5827c91529 ChangeLog 2082
+MD5 ad320b30cc2d11218429db26a97c208d ChangeLog 2213
MD5 258968ea5d81dab60459589a0c74f7c2 cl-tbnl-0.5.5.ebuild 981
-MD5 770ff213761e5b28c044713bba701d2a files/digest-cl-tbnl-0.5.5 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
+MD5 13a57ef6d8c46a29ceee1842cf0ac9f1 cl-tbnl-0.6.1.ebuild 981
+MD5 770ff213761e5b28c044713bba701d2a files/digest-cl-tbnl-0.5.5 66
+MD5 ddac1fb53cca7685915b56e8d9a7f2ff files/digest-cl-tbnl-0.6.1 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC8mmgI1lqEGTUzyQRArQ/AJ0YOa1IVD336+aJge0B4KqIA4YuDQCdG8ni
-Fvh1vKRuF5BMvPEOFySOOTQ=
-=VAbD
+iD8DBQFDIjEJyiNZaEAZA+ARAne1AJ9zPoyyoOeAZJ6TkjBZbg+f7vSFUwCfakbw
+/XRPuo1EmAF4m3m3VDm8UVw=
+=GHRA
-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.6.1.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.6.1.ebuild
new file mode 100644
index 000000000000..086101c0ea3b
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.6.1.ebuild,v 1.1 2005/09/10 01:03:01 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+ docinto test
+ dodoc test/*
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.6.1 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.6.1
new file mode 100644
index 000000000000..3ffe9b56b4ee
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.6.1
@@ -0,0 +1 @@
+MD5 fc5e7af9c7c127e3701000de3465e23b tbnl_0.6.1.orig.tar.gz 83761