summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 02:09:57 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 02:09:57 +0000
commit1c8d3f9c1df521dba90f6bccb13d10344f6fb1be (patch)
tree99570d04526963fed615c2e4d77a917ebe61209c /dev-lisp
parentfix license/repoman (diff)
downloadhistorical-1c8d3f9c1df521dba90f6bccb13d10344f6fb1be.tar.gz
historical-1c8d3f9c1df521dba90f6bccb13d10344f6fb1be.tar.bz2
historical-1c8d3f9c1df521dba90f6bccb13d10344f6fb1be.zip
fix license/repoman
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/plt/plt-202.ebuild37
-rw-r--r--dev-lisp/sbcl/sbcl-0.6.12.ebuild57
-rw-r--r--dev-lisp/sbcl/sbcl-0.7.5.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild5
-rw-r--r--dev-lisp/sbcl/sbcl-0.7.7.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.1.ebuild4
6 files changed, 44 insertions, 67 deletions
diff --git a/dev-lisp/plt/plt-202.ebuild b/dev-lisp/plt/plt-202.ebuild
index 76d6155586a4..d0b75dfedf76 100644
--- a/dev-lisp/plt/plt-202.ebuild
+++ b/dev-lisp/plt/plt-202.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/plt/plt-202.ebuild,v 1.4 2003/07/12 09:37:51 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/plt/plt-202.ebuild,v 1.5 2003/08/07 02:07:31 vapier Exp $
-S=${WORKDIR}/${PN}/src
DESCRIPTION="PLT Scheme, including DrScheme, mzscheme, mred, and mzc"
-SRC_URI="http://www.cs.utah.edu/plt/download/${PV}/plt/plt.src.x.tar.gz"
HOMEPAGE="http://www.plt-scheme.org/software/drscheme/"
+SRC_URI="http://www.cs.utah.edu/plt/download/${PV}/plt/plt.src.x.tar.gz"
+
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
DEPEND="virtual/glibc
virtual/x11
x11-libs/xaw
sys-devel/gcc
sys-devel/binutils"
-#RDEPEND=""
-KEYWORDS="x86"
-SLOT="0"
-LICENSE="LGPL-2.1"
+S=${WORKDIR}/${PN}/src
src_compile() {
-# cd src
./configure \
--host=${CHOST} \
--with-x \
@@ -28,8 +27,7 @@ src_compile() {
make || die
}
-src_install () {
-# cd src
+src_install() {
dodir usr/share/plt
make copytree || die
make mzinstall || die
@@ -40,7 +38,7 @@ src_install () {
# compile scheme sources to make startup quicker
/usr/bin/env PLTHOME=${D}/usr/share/plt \
- ${D}/usr/share/plt/bin/setup-plt || die
+ ${D}/usr/share/plt/bin/setup-plt || die
# move man files to correct location and delete
# them out of plt tree
@@ -50,18 +48,17 @@ src_install () {
# move misc package documentation to proper location
# and delete them out of plt tree
dodoc ${D}/usr/share/plt/notes/COPYING.LIB \
- ${D}/usr/share/plt/notes/mzscheme/*
+ ${D}/usr/share/plt/notes/mzscheme/*
rm -r ${D}/usr/share/plt/notes
# create executable scripts in /usr/bin which in turn call
# executables by the same name in /usr/share/plt with the
# correct PLTHOME path
- for f in mzc tex2page help-desk mred mzscheme drscheme setup-plt
- do
- target=${D}/usr/bin/$f
- echo '#! /bin/sh'> $target
- echo 'PLTHOME=/usr/share/plt ; export PLTHOME'>> $target
- echo 'exec ${PLTHOME}/bin/'$f' "$@"' >> $target
- chmod 755 $target
+ for f in mzc tex2page help-desk mred mzscheme drscheme setup-plt ; do
+ target=${D}/usr/bin/$f
+ echo '#! /bin/sh'> $target
+ echo 'PLTHOME=/usr/share/plt ; export PLTHOME'>> $target
+ echo 'exec ${PLTHOME}/bin/'$f' "$@"' >> $target
+ chmod 755 $target
done
}
diff --git a/dev-lisp/sbcl/sbcl-0.6.12.ebuild b/dev-lisp/sbcl/sbcl-0.6.12.ebuild
index a96888bd637f..e4aa7d7f10c1 100644
--- a/dev-lisp/sbcl/sbcl-0.6.12.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.6.12.ebuild
@@ -1,55 +1,42 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.6.12.ebuild,v 1.11 2003/02/28 16:54:59 liquidx Exp $
-
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.6.12.ebuild,v 1.12 2003/08/07 02:09:56 vapier Exp $
DESCRIPTION="SteelBank Common Lisp"
-
-SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
- mirror://sourceforge/sbcl/${P}-linux-binary.tar.bz2"
-
HOMEPAGE="http://sbcl.sourceforge.net/"
-
-PROVIDE="virtual/commonlisp"
+SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
+ mirror://sourceforge/sbcl/${P}-linux-binary.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="x86"
-src_unpack() {
-
- cd ${S}
+PROVIDE="virtual/commonlisp"
- unpack ${P}-linux-binary.tar.bz2 ; mv ${P} ${P}-binary
- unpack ${P}-source.tar.bz2
+src_unpack() {
+ unpack ${P}-linux-binary.tar.bz2 ; mv ${P} ${P}-binary
+ unpack ${P}-source.tar.bz2
}
src_compile() {
-
- export SBCL_HOME="../${P}-binary/output/"
- export GNUMAKE="make"
- try sh make.sh "../${P}-binary/src/runtime/sbcl"
-
- if which jade > /dev/null ; then
- cd doc ;
- try sh make-doc.sh ;
- else
- echo "Jade missing: Not building documentation" ;
- fi
+ export SBCL_HOME="../${P}-binary/output/"
+ export GNUMAKE="make"
+ sh make.sh "../${P}-binary/src/runtime/sbcl" || die "sh make.sh failed"
+
+ if which jade > /dev/null ; then
+ cd doc
+ sh make-doc.sh || die "sh make-doc.sh failed"
+ else
+ echo "Jade missing: Not building documentation"
+ fi
}
src_install() {
+ doman doc/sbcl.1
+ dobin src/runtime/sbcl
- into /usr
-
- doman doc/sbcl.1
- dobin src/runtime/sbcl
-
- dodoc BUGS CREDITS NEWS README INSTALL COPYING
-
- dodir /usr/share/sbcl
- cp output/sbcl.core ${D}/usr/share/sbcl/
+ dodoc BUGS CREDITS NEWS README INSTALL COPYING
+ insinto /usr/share/sbcl
+ doins output/sbcl.core
}
diff --git a/dev-lisp/sbcl/sbcl-0.7.5.ebuild b/dev-lisp/sbcl/sbcl-0.7.5.ebuild
index 75fe4c8ec8c0..60175202a2b3 100644
--- a/dev-lisp/sbcl/sbcl-0.7.5.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.7.5.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Copyright 2002 Marius Bernklev <mariube@unixcore.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.5.ebuild,v 1.7 2003/02/13 10:54:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.5.ebuild,v 1.8 2003/08/07 02:09:56 vapier Exp $
DESCRIPTION="Steel Bank Common Lisp"
HOMEPAGE="http://sbcl.sourceforge.net/"
@@ -10,6 +9,7 @@ BIN=${PN}-${BOOTSTRAPPER}
SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
mirror://sourceforge/sbcl/${BIN}-x86-linux-binary.tar.bz2
mirror://sourceforge/sbcl/${P}-html.tar.bz2"
+
LICENSE="MIT"
SLOT="0"
# 2002.07.19 -- karltk:
diff --git a/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild b/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild
index bfa13956bbfb..378daadaf3ee 100644
--- a/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild
@@ -1,9 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Copyright 2002 Marius Bernklev <mariube@unixcore.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild,v 1.6 2003/02/13 10:54:32 vapier Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.6-r1.ebuild,v 1.7 2003/08/07 02:09:57 vapier Exp $
DESCRIPTION="Steel Bank Common Lisp"
HOMEPAGE="http://sbcl.sourceforge.net/"
diff --git a/dev-lisp/sbcl/sbcl-0.7.7.ebuild b/dev-lisp/sbcl/sbcl-0.7.7.ebuild
index abde2c7ea0d4..04eadeb8d8f4 100644
--- a/dev-lisp/sbcl/sbcl-0.7.7.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.7.7.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Copyright 2002 Marius Bernklev <mariube@unixcore.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.7.ebuild,v 1.5 2003/07/12 09:37:51 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.7.7.ebuild,v 1.6 2003/08/07 02:09:57 vapier Exp $
DESCRIPTION="Steel Bank Common Lisp"
HOMEPAGE="http://sbcl.sourceforge.net/"
@@ -16,7 +15,6 @@ KEYWORDS="x86 ~ppc -sparc "
PROVIDE="virtual/commonlisp"
# the SRC_URI trickery needs this
DEPEND=">=sys-apps/portage-2.0.27"
-IUSE=""
src_unpack() {
diff --git a/dev-lisp/sbcl/sbcl-0.8.1.ebuild b/dev-lisp/sbcl/sbcl-0.8.1.ebuild
index 2ca211d4a230..b29ca16d58b1 100644
--- a/dev-lisp/sbcl/sbcl-0.8.1.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.1.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Copyright 2002 Marius Bernklev <mariube@unixcore.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.1.ebuild,v 1.1 2003/06/28 13:29:23 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.1.ebuild,v 1.2 2003/08/07 02:09:57 vapier Exp $
DESCRIPTION="Steel Bank Common Lisp"
HOMEPAGE="http://sbcl.sourceforge.net/"
@@ -18,7 +17,6 @@ KEYWORDS="~x86 ~ppc -sparc "
PROVIDE="virtual/commonlisp"
# the SRC_URI trickery needs this
DEPEND=">=sys-apps/portage-2.0.27"
-IUSE=""
src_unpack() {