summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:57:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:57:01 +0000
commit818e688ff051c1c3b88d53eea1036e19bc5a773f (patch)
tree5c4b42cac9768fd5fd19814ec2bf3fb568b99422 /dev-ml/core
parentversion bump (diff)
downloadhistorical-818e688ff051c1c3b88d53eea1036e19bc5a773f.tar.gz
historical-818e688ff051c1c3b88d53eea1036e19bc5a773f.tar.bz2
historical-818e688ff051c1c3b88d53eea1036e19bc5a773f.zip
version bump, by Vladimir Ivanov, bug #361171
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog7
-rw-r--r--dev-ml/core/core-0.7.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 2cf4e3c9a72b..5c2826565aab 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.3 2011/02/24 20:12:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.4 2011/06/25 18:57:01 aballier Exp $
+
+*core-0.7.0 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org> +core-0.7.0.ebuild:
+ version bump, by Vladimir Ivanov, bug #361171
*core-0.7.0_beta1 (24 Feb 2011)
diff --git a/dev-ml/core/core-0.7.0.ebuild b/dev-ml/core/core-0.7.0.ebuild
new file mode 100644
index 000000000000..3d355ca602fd
--- /dev/null
+++ b/dev-ml/core/core-0.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.7.0.ebuild,v 1.1 2011/06/25 18:57:01 aballier Exp $
+
+EAPI="2"
+inherit findlib eutils multilib
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/res
+ >=dev-ml/sexplib-5.2.1
+ >=dev-ml/bin-prot-1.3.1
+ >=dev-ml/fieldslib-0.1.2"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+}