summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-23 20:39:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-23 20:39:42 +0000
commit90fda7d9c11531d2cec01d1c01a0d3a534f9711c (patch)
tree92f91a587e88957975d1b5c91177fb2d0960ec61 /dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild
parentUpdate comment about x11-libs/qt-qt3support-4.8.0-r1 mask. (diff)
downloadhistorical-90fda7d9c11531d2cec01d1c01a0d3a534f9711c.tar.gz
historical-90fda7d9c11531d2cec01d1c01a0d3a534f9711c.tar.bz2
historical-90fda7d9c11531d2cec01d1c01a0d3a534f9711c.zip
remove old
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild')
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild
deleted file mode 100644
index c96a5ea337a0..000000000000
--- a/dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.7.1.ebuild,v 1.5 2012/02/05 18:33:08 armin76 Exp $
-
-inherit findlib
-
-DESCRIPTION="OCaml SDL Bindings"
-
-HOMEPAGE="http://ocamlsdl.sourceforge.net"
-SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
-LICENSE="LGPL-2"
-
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE="doc opengl truetype" #noimage nomixer
-
-DEPEND=">=dev-lang/ocaml-3.04
->=media-libs/libsdl-1.2
-opengl? ( >=dev-ml/lablgl-0.98 )
->=media-libs/sdl-mixer-1.2
->=media-libs/sdl-image-1.2
-truetype? ( >=media-libs/sdl-ttf-2.0 )"
-
-src_compile() {
- myconf=""
- if use opengl; then
- destdir=`ocamlfind printconf destdir`
- lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
- if [ -z "${lablgldir}" ]; then
- destdir=`ocamlc -where`
- lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
- fi
-
- if [ ! -z "${lablgldir}" ]; then
- myconf="--with-lablgldir=${lablgldir}"
- fi
- fi
-
- #use noimage && myconf="${myconf} --without-sdl-image"
- #use nomixer && myconf="${myconf} --without-sdl-mixer"
-
- econf $myconf \
- `use_enable truetype sdl-ttf` \
- || die
- emake all || die
-}
-
-src_install() {
- findlib_src_install
-
- dodoc AUTHORS NEWS README
- doinfo doc/*.info*
-
- if use doc; then
- dohtml doc/html/*
- fi
-}