summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-29 13:51:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-29 13:51:53 +0000
commit50ca755bd232ac9fb8b0d22cc13953975302035e (patch)
tree6870a76b6d2b6b46e9052f8e8362a05c8d55e306 /dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild
parentversion bump, update live ebuild (diff)
downloadhistorical-50ca755bd232ac9fb8b0d22cc13953975302035e.tar.gz
historical-50ca755bd232ac9fb8b0d22cc13953975302035e.tar.bz2
historical-50ca755bd232ac9fb8b0d22cc13953975302035e.zip
version bump
Signed-off-by: aballier@gentoo.org Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild
new file mode 100644
index 000000000000..60d4c2724c20
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.1.ebuild,v 1.1 2014/10/29 13:51:49 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql-base
+ dev-db/postgresql-server
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}