summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-17 08:47:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-17 08:47:41 +0000
commit5ab305c9139c8a7eab48d68904d757dee2f91aa5 (patch)
tree66a891003aa5f40ed3bea268f5977c5ac4bf81a0 /dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing
parentanother slotmove for gtksourceview, should be fine this time (diff)
downloadhistorical-5ab305c9139c8a7eab48d68904d757dee2f91aa5.tar.gz
historical-5ab305c9139c8a7eab48d68904d757dee2f91aa5.tar.bz2
historical-5ab305c9139c8a7eab48d68904d757dee2f91aa5.zip
Initial commit. Ebuild by Robin H. Johnnson <robbat2@gentoo.org>.
Package-Manager: portage-2.1.3.14
Diffstat (limited to 'dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing')
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog12
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild44
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest28
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf18
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.033
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre3
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh17
-rw-r--r--dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml9
8 files changed, 134 insertions, 0 deletions
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog
new file mode 100644
index 000000000000..4bba7889e76a
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/ChangeLog,v 1.1 2007/10/17 08:47:40 robbat2 Exp $
+
+*Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03 (17 Oct 2007)
+
+ 17 Oct 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/24_google_safebrowsing.cf, +files/init_google_safebrowsing.pre,
+ +files/update_google_safebrowsing.sh, +metadata.xml,
+ +Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild:
+ Initial commit. Ebuild by Robin H. Johnnson <robbat2@gentoo.org>.
+
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild
new file mode 100644
index 000000000000..1788a5787d70
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild,v 1.1 2007/10/17 08:47:40 robbat2 Exp $
+
+MODULE_AUTHOR="DANBORN"
+inherit perl-module
+
+DESCRIPTION="SpamAssassin plugin to score mail based on Google blocklists."
+
+IUSE="test"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+RDEPEND="dev-perl/Net-Google-SafeBrowsing-Blocklist
+ dev-perl/Net-Google-SafeBrowsing-UpdateRequest
+ mail-filter/spamassassin"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod )"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ insinto /etc/mail/spamassassin
+ doins "${FILESDIR}"/init_google_safebrowsing.pre
+ doins "${FILESDIR}"/24_google_safebrowsing.cf
+ exeinto /etc/cron.d/
+ doexe "${FILESDIR}"/update_google_safebrowsing.sh
+ keepdir /var/lib/spamassassin/google_safebrowsing/
+}
+
+pkg_postinst() {
+ elog "To use this package:"
+ elog "1. You MUST apply for a free apikey at:"
+ elog " http://code.google.com/apis/safebrowsing/key_signup.html"
+ elog "2. Place the key into /etc/mail/spamassassin/24_google_safebrowsing.cf"
+ elog "3. Manually run the cronjob /etc/cron.d/update_google_safebrowsing.sh"
+ elog "4. Configure the cronjob to run every 25-30 minutes. "
+ elog " Don't choose round numbers!"
+ elog "5. Enable the plugin by uncommenting the loadplugin entry in"
+ elog " /etc/mail/spamassassin/init_google_safebrowsing.pre"
+ elog "6. Restart spamd"
+}
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest
new file mode 100644
index 000000000000..4cdb97093b60
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/Manifest
@@ -0,0 +1,28 @@
+AUX 24_google_safebrowsing.cf 734 RMD160 bb5ab4e0d30f5eb6fddaf14bbcf5f68829b2f192 SHA1 31754ee284bab2b5486d21f63e213a3c5da398c4 SHA256 2681743d5c67153df967d424aa54f83da2c618fd25e7cb4b3642f4c25f949fd4
+MD5 e39583a92efff6b940bc5cbde2df8d61 files/24_google_safebrowsing.cf 734
+RMD160 bb5ab4e0d30f5eb6fddaf14bbcf5f68829b2f192 files/24_google_safebrowsing.cf 734
+SHA256 2681743d5c67153df967d424aa54f83da2c618fd25e7cb4b3642f4c25f949fd4 files/24_google_safebrowsing.cf 734
+AUX init_google_safebrowsing.pre 305 RMD160 77865eaf8173678245a4331ce2fe190512bb85e6 SHA1 bf090f1f9b1b85b2e7448c6492864127db413ed7 SHA256 73cccca5cd99c025e3713aea672db4d0bfaac28472887ae7d4bc2c3da7f6ab77
+MD5 6aff24d6bb06d7d0b745c6e25e8cea38 files/init_google_safebrowsing.pre 305
+RMD160 77865eaf8173678245a4331ce2fe190512bb85e6 files/init_google_safebrowsing.pre 305
+SHA256 73cccca5cd99c025e3713aea672db4d0bfaac28472887ae7d4bc2c3da7f6ab77 files/init_google_safebrowsing.pre 305
+AUX update_google_safebrowsing.sh 1030 RMD160 ce3cebddde292ad018e982aa53bb731b493acd26 SHA1 4af296d75ac4c91e6b2f3cfb7841a4d7af12e01e SHA256 5761d25c29facb02e249f795d6c550f2213761f630aff5a1401303131f0a0f31
+MD5 1308cbe060d4fade126a38d3facfc5d5 files/update_google_safebrowsing.sh 1030
+RMD160 ce3cebddde292ad018e982aa53bb731b493acd26 files/update_google_safebrowsing.sh 1030
+SHA256 5761d25c29facb02e249f795d6c550f2213761f630aff5a1401303131f0a0f31 files/update_google_safebrowsing.sh 1030
+DIST Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.tar.gz 4253 RMD160 3169cc45221608abf6a79f8208776e8bc01390f1 SHA1 66f029c5bde1d7c8a9180b7eca04c56ea1d55e77 SHA256 39d1ddc4f539411a1c34cd96f6d0a84b4f4651c2aa08b7e596a09d4b1b718fa7
+EBUILD Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild 1559 RMD160 5264c1248c3743fcda455d41af3508943f92d90f SHA1 308ab281d523e0b263d8cf2e9a3618c196392327 SHA256 5f22378a4d2728026417b3fe29b18167a4e1d6c369eae15cad3441ba933ab031
+MD5 6aff47378e913c319f2359b68ca8f8f0 Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild 1559
+RMD160 5264c1248c3743fcda455d41af3508943f92d90f Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild 1559
+SHA256 5f22378a4d2728026417b3fe29b18167a4e1d6c369eae15cad3441ba933ab031 Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.ebuild 1559
+MISC ChangeLog 653 RMD160 eaa53bf23674be9fe2f204d42d7224f8b633241e SHA1 86a61e1f417bce2189fb85c238e1347bd711184e SHA256 05b1cac30ea2ef88f66a529026691421b0a6a5dbc8c1fa95fe2ae9f124b73417
+MD5 f28435d6afa2eab2dc924a65dce1bbf6 ChangeLog 653
+RMD160 eaa53bf23674be9fe2f204d42d7224f8b633241e ChangeLog 653
+SHA256 05b1cac30ea2ef88f66a529026691421b0a6a5dbc8c1fa95fe2ae9f124b73417 ChangeLog 653
+MISC metadata.xml 271 RMD160 33d1e6d38b3ecde19f2a3a873476e4fc03fd0a41 SHA1 1b49b2ba691f42cbf4f86231769f560b7232453a SHA256 0670df6d1cf19fc80b5a9b574234d0d260f42c2c1889155d94922b0d63976ac2
+MD5 2df9d8023d665f58666b098375350645 metadata.xml 271
+RMD160 33d1e6d38b3ecde19f2a3a873476e4fc03fd0a41 metadata.xml 271
+SHA256 0670df6d1cf19fc80b5a9b574234d0d260f42c2c1889155d94922b0d63976ac2 metadata.xml 271
+MD5 82cde717ee651f19497d9efb5d9fd9ef files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03 340
+RMD160 8a7fa952e99a4a1db2e918a9227354d2951a62f3 files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03 340
+SHA256 8186bfc483bbda2d2d16288717e1b8c391b35bb68b1882d5cc8752c6de3db540 files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03 340
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf
new file mode 100644
index 000000000000..82098023bf80
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf
@@ -0,0 +1,18 @@
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/24_google_safebrowsing.cf,v 1.1 2007/10/17 08:47:41 robbat2 Exp $
+ifplugin Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
+
+# Replace DEADBEEF with your API key
+# from http://code.google.com/apis/safebrowsing/key_signup.html
+google_safebrowsing_apikey DEADBEEF
+
+# Change these scores if you want
+google_safebrowsing_blocklist goog-black-hash 0.2
+google_safebrowsing_blocklist goog-malware-hash 0.1
+
+# Do not change these two lines!
+body GOOGLE_SAFEBROWSING eval:check_google_safebrowsing_blocklists()
+google_safebrowsing_dir /var/lib/spamassassin/google_safebrowsing/
+
+endif # Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
+
+# vim: ft=conf:
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03 b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03
new file mode 100644
index 000000000000..babd02b00872
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/digest-Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03
@@ -0,0 +1,3 @@
+MD5 76b25e037d7b293631aa88ceb59e90be Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.tar.gz 4253
+RMD160 3169cc45221608abf6a79f8208776e8bc01390f1 Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.tar.gz 4253
+SHA256 39d1ddc4f539411a1c34cd96f6d0a84b4f4651c2aa08b7e596a09d4b1b718fa7 Mail-SpamAssassin-Plugin-GoogleSafeBrowsing-1.03.tar.gz 4253
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre
new file mode 100644
index 000000000000..be174ff5eab2
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre
@@ -0,0 +1,3 @@
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/init_google_safebrowsing.pre,v 1.1 2007/10/17 08:47:41 robbat2 Exp $
+# You need to uncomment this after you have an API key and the cronjob is active!
+#loadplugin Mail::SpamAssassin::Plugin::GoogleSafeBrowsing
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh
new file mode 100644
index 000000000000..72b89fcabce9
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/files/update_google_safebrowsing.sh,v 1.1 2007/10/17 08:47:41 robbat2 Exp $
+# This cron script updates the Google SafeBrowsing lists for the use of the
+# Mail-SpamAssassin-Plugin-GoogleSafeBrowsing plugin.
+# It should be run every 25-30 minutes! http://code.google.com/apis/safebrowsing/developers_guide.html#AcceptableUsage
+CONFFILE="/etc/mail/spamassassin/24_google_safebrowsing.cf"
+OUTDIR="$(awk '/^google_safebrowsing_dir/{print $2}' "${CONFFILE}")"
+APIKEY="$(awk '/^google_safebrowsing_apikey/{print $2}' "${CONFFILE}")"
+LISTS="$(awk '/^google_safebrowsing_blocklist/{printf "%s ",$2}' "${CONFFILE}")"
+# Wait a little while, to avoid hammering the server
+sleep $(($RANDOM % 120))
+# Use LISTS unquoted!
+for LIST in ${LISTS}; do
+ blocklist_updater --apikey "$APIKEY" --blocklist ${LIST} --dbfile ${OUTDIR}/${LIST}-db
+done
diff --git a/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml
new file mode 100644
index 000000000000..8ac7a1c994df
--- /dev/null
+++ b/dev-perl/Mail-SpamAssassin-Plugin-GoogleSafeBrowsing/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+</pkgmetadata>