summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Lipelis <aeoo@gentoo.org>2002-02-25 05:39:43 +0000
committerLeo Lipelis <aeoo@gentoo.org>2002-02-25 05:39:43 +0000
commit0d537c7d868563198346a399753bd0d81ad47e7c (patch)
treee4d1aa5adc7d4c856f89d2f0a9a392b3680a145b /dev-perl
parenttab fixes (diff)
downloadhistorical-0d537c7d868563198346a399753bd0d81ad47e7c.tar.gz
historical-0d537c7d868563198346a399753bd0d81ad47e7c.tar.bz2
historical-0d537c7d868563198346a399753bd0d81ad47e7c.zip
initial ebuild for perl SDL binding
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SDL-sdlpl/ChangeLog30
-rw-r--r--dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild39
-rw-r--r--dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.121
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/SDL-sdlpl/ChangeLog b/dev-perl/SDL-sdlpl/ChangeLog
new file mode 100644
index 000000000000..09090ac86b08
--- /dev/null
+++ b/dev-perl/SDL-sdlpl/ChangeLog
@@ -0,0 +1,30 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SDL-sdlpl/ChangeLog,v 1.1 2002/02/25 05:39:43 aeoo Exp $
+
+ 25 Feb 2002; Leo Lipelis <aeoo@gentoo.org> files/digest-SDL-sdlpl-1.12,
+ SDL-sdlpl-1.12.ebuild:
+
+ Initial ebuild.
+
+*SDL-sdlpl-1.12 (25 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> skel.ChangeLog :
+
+ This changelog is targetted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package has to be marked by a '*'
+ seperator line as above. Changements since the last revision have to be
+ added to the top of the file, underneath the initial copyright and cvs header
+ comments, in exactly the same format as this comment.
+
+ This means that you start with header line that has the following format :
+
+ date; your_name <your_email> changed_file1, changed_file2 :
+
+ Below that line your explanation should follow. It has to be indented,
+ paragraphed and wrapped at a linewidth of 80 characters.
+
+ Any details about what exactly changed in the code should be added as a
+ message when the changes are committed to cvs, not in this file.
diff --git a/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild b/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild
new file mode 100644
index 000000000000..6d3ee66c24c8
--- /dev/null
+++ b/dev-perl/SDL-sdlpl/SDL-sdlpl-1.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# distributed under the terms of the GNU General Pulic License, v2.
+# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SDL binding for perl"
+HOMEPAGE="http://sdlperl.org/"
+SRC_URI="http://sdlperl.org/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ virtual/opengl
+ >=sys-devel/perl-5.6.1
+ >=media-libs/sdl-mixer-1.0.5
+ >=media-libs/sdl-image-1.0.0"
+
+src_unpack()
+{
+ unpack "${A}"
+
+ # Patch 'Makefile.PL' to use '/usr/include/SDL'
+ # instead of '/usr/local/include/SDL' ...
+ cp "${P}/Makefile.PL" "${P}/Makefile.PL.orig"
+ sed 's:/usr/local/include:/usr/include:g' < "${P}/Makefile.PL.orig" > "${P}/Makefile.PL"
+ assert "Patching Makefile.PL failed !"
+}
+
+src_compile ()
+{
+ perl Makefile.PL || die
+ make || die
+}
+
+src_install ()
+{
+ make PREFIX="${D}/usr" INSTALLMAN3DIR="${D}/usr/share/man/man3" install || die
+ dodoc BUGS COPYING README TODO
+}
+
diff --git a/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12 b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12
new file mode 100644
index 000000000000..848b6c1c29bd
--- /dev/null
+++ b/dev-perl/SDL-sdlpl/files/digest-SDL-sdlpl-1.12
@@ -0,0 +1 @@
+MD5 e6f19fdfe4df0358c6bc4c458dc9bce5 SDL-sdlpl-1.12.tar.gz 164394