summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-30 18:24:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-30 18:24:34 +0000
commitb4ac26f59dc91b3f61256f35e5dd94277fbb48e8 (patch)
tree068caa10f95726f1816327996c8fed5e5913261e /dev-perl
parentAdded slirp a SLIP/PPP emulator for terminals (diff)
downloadhistorical-b4ac26f59dc91b3f61256f35e5dd94277fbb48e8.tar.gz
historical-b4ac26f59dc91b3f61256f35e5dd94277fbb48e8.tar.bz2
historical-b4ac26f59dc91b3f61256f35e5dd94277fbb48e8.zip
*** empty log message ***
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBI/DBI-1.14.ebuild5
-rw-r--r--dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild5
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild4
-rw-r--r--dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild5
-rw-r--r--dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild3
-rw-r--r--dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild4
-rw-r--r--dev-perl/PDL/PDL-2.2.ebuild6
-rw-r--r--dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild4
-rw-r--r--dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild4
-rw-r--r--dev-perl/Unicode-String/Unicode-String-2.06.ebuild7
-rw-r--r--dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild6
11 files changed, 26 insertions, 27 deletions
diff --git a/dev-perl/DBI/DBI-1.14.ebuild b/dev-perl/DBI/DBI-1.14.ebuild
index 34895e88ea03..3b0bd9b8a030 100644
--- a/dev-perl/DBI/DBI-1.14.ebuild
+++ b/dev-perl/DBI/DBI-1.14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBI/DBI-1.14.ebuild,v 1.3 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBI/DBI-1.14.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,8 @@ DESCRIPTION="The Perl DBI Module"
SRC_URI="http://www.cpan.org/modules/by-module/DBI/${A}"
HOMEPAGE="http://www.cpan.org/modules/by-module/DBI/${P}.readme"
-DEPEND=">=sys-devel/perl-5
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5
>=dev-perl/PlRPC-0.2"
src_compile() {
diff --git a/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild b/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild
index d66cb97631d2..3c2fc060f9d5 100644
--- a/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild
+++ b/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild,v 1.7 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Digest-MD5/Digest-MD5-2.12.ebuild,v 1.8 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,8 +9,7 @@ DESCRIPTION="A URI Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-category/14_Security_and_Encryption/Digest/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/14_Security_and_Encryption/Digest/${P}.readme"
-DEPEND=">=sys-devel/perl-5
- >=sys-libs/glibc-2.1.3"
+DEPEND=">=sys-devel/perl-5 virtual/glibc"
src_compile() {
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild
index 67b521266180..3586766ce007 100644
--- a/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild,v 1.2 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.0.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,7 +9,7 @@ DESCRIPTION="A HTML development and delivery Perl Module"
SRC_URI="http://www.masonhq.com/download/${A}"
HOMEPAGE="http://www.masonhq.com/"
-DEPEND=">=sys-devel/perl-5"
+DEPEND=">=sys-devel/perl-5 dev-perl/Time-HiRes dev-perl/MLDBM"
src_compile() {
diff --git a/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild b/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild
index 23eb1b0ad088..db7f0d3043e6 100644
--- a/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild
+++ b/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild,v 1.5 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MIME-Base64/MIME-Base64-2.11.ebuild,v 1.6 2001/05/30 18:24:34 achim Exp $
P=MIME-Base64-2.11
A=${P}.tar.gz
@@ -11,8 +11,7 @@ DESCRIPTION="A base64/quoted-printable encoder/decoder Perl Modules"
SRC_URI="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/MIME/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/MIME/${P}.readme"
-DEPEND=">=sys-devel/perl-5
- >=sys-libs/glibc-2.1.3"
+DEPEND=">=sys-devel/perl-5 virtual/glibc"
src_compile() {
diff --git a/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild b/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild
index d8eacf714b1c..a413e311b294 100644
--- a/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild
+++ b/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild,v 1.2 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-Audit/Mail-Audit-1.8.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,7 +11,6 @@ SRC_URI="http://www.cpan.org/modules/by-module/Mail/${A}"
HOMEPAGE="http://www.cpan.org/modules/by-module/Mail/${P}.readme"
DEPEND=">=sys-devel/perl-5
- >=dev-perl/libnet-1.0703
>=dev-perl/POP3Client-2.7
>=dev-perl/MailTools-1.15"
diff --git a/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild b/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild
index deaa8a0760df..0174b344eb07 100644
--- a/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild
+++ b/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild,v 1.2 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-Procmail/Mail-Procmail-1.01.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,7 +11,7 @@ SRC_URI="http://www.cpan.org/modules/by-module/Mail/${A}"
HOMEPAGE="http://www.cpan.org/modules/by-module/Mail/${P}.readme"
DEPEND=">=sys-devel/perl-5
- >=dev-perl/libnet-1.0703
+ >=dev-perl/MailTools-1.15
>=dev-perl/LockFile-Simple-0.2.5"
src_compile() {
diff --git a/dev-perl/PDL/PDL-2.2.ebuild b/dev-perl/PDL/PDL-2.2.ebuild
index b1c5375b6593..01f2384fe1b4 100644
--- a/dev-perl/PDL/PDL-2.2.ebuild
+++ b/dev-perl/PDL/PDL-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.2.ebuild,v 1.5 2001/04/24 01:22:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.2.ebuild,v 1.6 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,8 +11,8 @@ HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
DEPEND=">=sys-devel/perl-5
>=sys-libs/ncurses-5.2
- >=dev-perl/ExtUtils-F77-1.13
- opengl? ( virtual/opengl )"
+ >=dev-perl/ExtUtils-F77-1.13"
+ #opengl? ( virtual/opengl )"
src_unpack() {
diff --git a/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild b/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild
index 0a5e4b047dde..5b7c7eb03aab 100644
--- a/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild
+++ b/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild,v 1.3 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Time-HiRes/Time-HiRes-01.20.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,7 +9,7 @@ DESCRIPTION="A Precise Time Perl Module"
SRC_URI="http://www.cpan.org/modules/by-module/Time/${A}"
HOMEPAGE="http://www.cpan.org/modules/by-module/Time/${P}.readme"
-DEPEND=">=sys-devel/perl-5"
+DEPEND=">=sys-devel/perl-5 virtual/glibc"
src_compile() {
perl Makefile.PL
diff --git a/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild b/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild
index 62dbf1387c9c..20a16cd50a1e 100644
--- a/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild
+++ b/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild,v 1.2 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Unicode-Map8/Unicode-Map8-0.10.ebuild,v 1.3 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,7 +9,7 @@ DESCRIPTION="A Unicode Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-module/Unicode/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/Unicode/${P}.readme"
-DEPEND=">=sys-devel/perl-5
+DEPEND="virtual/glibc >=sys-devel/perl-5
>=dev-perl/Unicode-String-2.06"
src_compile() {
diff --git a/dev-perl/Unicode-String/Unicode-String-2.06.ebuild b/dev-perl/Unicode-String/Unicode-String-2.06.ebuild
index 43f1c5dfd508..29709aaf3040 100644
--- a/dev-perl/Unicode-String/Unicode-String-2.06.ebuild
+++ b/dev-perl/Unicode-String/Unicode-String-2.06.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Unicode-String/Unicode-String-2.06.ebuild,v 1.3 2001/05/17 13:26:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Unicode-String/Unicode-String-2.06.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,8 @@ SRC_URI="http://cpan.valueclick.com/modules/by-module/Unicode/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/Unicode/${P}.readme"
DEPEND=">=sys-devel/perl-5
- >=dev-perl/MIME-Base64-2.11"
+ >=dev-perl/MIME-Base64-2.11
+ virtual/glibc"
src_compile() {
@@ -22,7 +23,7 @@ src_compile() {
src_install () {
try make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 install
- dodoc ChangeLog MANIFEST README* TODO
+ dodoc MANIFEST README*
}
diff --git a/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild b/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild
index 543ccc9338c7..d00f8411e697 100644
--- a/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild
+++ b/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild,v 1.3 2001/05/09 10:21:22 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXSLT/XML-LibXSLT-0.96.ebuild,v 1.4 2001/05/30 18:24:34 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,7 @@ SRC_URI="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${P}.readme"
DEPEND=">=sys-devel/perl-5
- >=gnome-base/gnome-libs-1.2.10
+ >=gnome-base/gnome-libs-1
>=gnome-libs/libxslt-0.5
>=dev-perl/libwww-perl-5.48"
@@ -22,7 +22,7 @@ src_unpack() {
src_compile() {
- perl Makefile.PL
+ perl Makefile.PL LIBS=\"-L/opt/gnome/lib\" INC=\"-I/opt/gnome/include\"
try make
try make test
}