summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-02-16 05:07:11 +0000
committerSteve Dibb <beandog@gentoo.org>2010-02-16 05:07:11 +0000
commitce95174ae34f857de4559aad99802dc0e1e2ea9b (patch)
tree2af556d371fe8b82dc75efdc9df3e98fb8d9c79e /dev-php/PEAR-Auth
parentRemove PDEPEND upon dev-php/pear, as the eclass will pull it in directly now (diff)
downloadhistorical-ce95174ae34f857de4559aad99802dc0e1e2ea9b.tar.gz
historical-ce95174ae34f857de4559aad99802dc0e1e2ea9b.tar.bz2
historical-ce95174ae34f857de4559aad99802dc0e1e2ea9b.zip
Version bump
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-php/PEAR-Auth')
-rw-r--r--dev-php/PEAR-Auth/ChangeLog9
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-php/PEAR-Auth/ChangeLog b/dev-php/PEAR-Auth/ChangeLog
index 9ab9a8eaa4ff..ee8ac8ab0e33 100644
--- a/dev-php/PEAR-Auth/ChangeLog
+++ b/dev-php/PEAR-Auth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Auth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.42 2009/08/22 22:30:46 beandog Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.43 2010/02/16 04:25:25 beandog Exp $
+
+*PEAR-Auth-1.6.2 (16 Feb 2010)
+
+ 16 Feb 2010; Steve Dibb <beandog@gentoo.org> +PEAR-Auth-1.6.2.ebuild:
+ Version bump
*PEAR-Auth-1.6.1 (22 Aug 2009)
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild
new file mode 100644
index 000000000000..f22ffbcd28f8
--- /dev/null
+++ b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild,v 1.1 2010/02/16 04:25:25 beandog Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+DESCRIPTION="Provides methods for creating an authentication system using PHP."
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
+ >=dev-php/PEAR-File_Passwd-1.1.0
+ >=dev-php/PEAR-Net_POP3-1.3.0
+ >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-MDB
+ >=dev-php/PEAR-MDB2-2.0.0_rc1
+ >=dev-php/PEAR-Crypt_CHAP-1.0.0
+ >=dev-php/PEAR-SOAP-0.9.0
+ >=dev-php/PEAR-File_SMBPasswd-1.0.0 )"
+ # missing lots of keywords
+ # >=dev-php/PEAR-HTTP_Client-1.1.0
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} imap soap ; then
+ elog "${PN} can optionally use ${PHP_PKG} imap and soap features."
+ elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
+ fi
+}