summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-12 21:42:55 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-12 21:42:55 +0000
commite9a7c0856a7fbd303b6f1e09b35ed0bfa9b931ee (patch)
treef6cb916942b7fa4ac4d53c07e5bcc7abbc42a0fd /dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild
parentfix typo in CL (diff)
downloadhistorical-e9a7c0856a7fbd303b6f1e09b35ed0bfa9b931ee.tar.gz
historical-e9a7c0856a7fbd303b6f1e09b35ed0bfa9b931ee.tar.bz2
historical-e9a7c0856a7fbd303b6f1e09b35ed0bfa9b931ee.zip
eapi bump
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild b/dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..98574437b3d5
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-HTTP_Download/PEAR-HTTP_Download-1.1.3-r1.ebuild,v 1.1 2010/06/12 21:42:55 mabi Exp $
+
+EAPI="2"
+
+inherit php-pear-r1 eutils
+
+DESCRIPTION="Provides functionality to send HTTP downloads."
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+RDEPEND="${DEPEND}
+ dev-php/PEAR-HTTP_Header
+ !minimal? ( dev-php/PEAR-MIME_Type )"
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} postgres ; then
+ elog "${PN} can optionally use ${PHP_PKG} postgres features."
+ elog "If you want those, recompile ${PHP_PKG} with this flags in USE."
+ fi
+}