summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-03-24 13:28:46 +0000
committerBrian Evans <grknight@gentoo.org>2015-03-24 13:28:46 +0000
commit4b93e0383967cd0cb684d7e983955ffd59eda642 (patch)
tree1e6b95243f3988838aded3fe00a29d0e09d1604e /dev-php/pecl-redis/pecl-redis-2.2.7.ebuild
parentClean up patches for upcoming stabilization. (diff)
downloadhistorical-4b93e0383967cd0cb684d7e983955ffd59eda642.tar.gz
historical-4b93e0383967cd0cb684d7e983955ffd59eda642.tar.bz2
historical-4b93e0383967cd0cb684d7e983955ffd59eda642.zip
Version bump; make igbinary dependency more specific
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0xD1F781EFF9F4A3B6
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-2.2.7.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild
new file mode 100644
index 000000000000..0a44a053d09a
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-redis/pecl-redis-2.2.7.ebuild,v 1.1 2015/03/24 13:28:34 grknight Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="This extension provides an API for communicating with Redis servers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? ( php_targets_php5-4? ( dev-php/igbinary[php_targets_php5-4] )
+ php_targets_php5-5? ( dev-php/igbinary[php_targets_php5-5] )
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}