summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-19 16:50:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-19 16:50:17 +0000
commit1921cc4f3ae16544bccc475f3ba7404543b8842a (patch)
tree3c9cc0b293fe567c8d6c43fcc1a7d50d6674bcd4 /dev-python/couchdb-python/couchdb-python-0.6.1.ebuild
parentRevision bump to stop building hid2hci (bug #315749) (diff)
downloadhistorical-1921cc4f3ae16544bccc475f3ba7404543b8842a.tar.gz
historical-1921cc4f3ae16544bccc475f3ba7404543b8842a.tar.bz2
historical-1921cc4f3ae16544bccc475f3ba7404543b8842a.zip
Restore couchdb-python-0.6.1.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/couchdb-python/couchdb-python-0.6.1.ebuild')
-rw-r--r--dev-python/couchdb-python/couchdb-python-0.6.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/couchdb-python/couchdb-python-0.6.1.ebuild b/dev-python/couchdb-python/couchdb-python-0.6.1.ebuild
new file mode 100644
index 000000000000..f2038ccbb170
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/couchdb-python/couchdb-python-0.6.1.ebuild,v 1.6 2010/06/19 16:50:17 arfrever Exp $
+
+EAPI="2"
+
+inherit distutils
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="http://code.google.com/p/couchdb-python/ http://pypi.python.org/pypi/CouchDB"
+SRC_URI="http://pypi.python.org/packages/source/C/CouchDB/CouchDB-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="dev-python/httplib2
+ || ( >=dev-lang/python-2.6
+ ( dev-lang/python:2.5 dev-python/simplejson )
+ ( dev-lang/python:2.4 dev-python/simplejson ) )
+ doc? ( dev-python/epydoc )"
+DEPEND="dev-python/setuptools"
+
+PYTHON_MODNAME="couchdb"
+S="${WORKDIR}/CouchDB-${PV}"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ epydoc --config=doc/conf/epydoc.ini
+ fi
+
+ dohtml -r doc/* || die "dohtml failed"
+}
+
+src_test() {
+ python setup.py test
+}