summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-10-03 04:48:15 +0000
committerRyan Hill <rhill@gentoo.org>2007-10-03 04:48:15 +0000
commit8fe99c23dc86cb325f63374c486ea044711d68fd (patch)
tree260373ec32aa56cf275bc09cd03163c290f3e811 /dev-python/drpython
parentLock wxpython dependency. (diff)
downloadhistorical-8fe99c23dc86cb325f63374c486ea044711d68fd.tar.gz
historical-8fe99c23dc86cb325f63374c486ea044711d68fd.tar.bz2
historical-8fe99c23dc86cb325f63374c486ea044711d68fd.zip
Lock wxpython dependency. Fix quoting.
Package-Manager: portage-2.1.3.11
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/ChangeLog5
-rw-r--r--dev-python/drpython/drpython-164.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/drpython/ChangeLog b/dev-python/drpython/ChangeLog
index 714c6577a1c6..021fc73c829a 100644
--- a/dev-python/drpython/ChangeLog
+++ b/dev-python/drpython/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/drpython
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.12 2007/03/04 10:13:32 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.13 2007/10/03 04:48:15 dirtyepic Exp $
+
+ 03 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> drpython-164.ebuild:
+ Lock wxpython dependency. Fix quoting.
04 Mar 2007; Lukasz Strzygowski <lucass@gentoo.org> drpython-164.ebuild:
Replaced einfo with elog in pkg_postinst.
diff --git a/dev-python/drpython/drpython-164.ebuild b/dev-python/drpython/drpython-164.ebuild
index 599e6e6ea3e7..b86490d318c1 100644
--- a/dev-python/drpython/drpython-164.ebuild
+++ b/dev-python/drpython/drpython-164.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-164.ebuild,v 1.2 2007/03/04 10:13:32 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-164.ebuild,v 1.3 2007/10/03 04:48:15 dirtyepic Exp $
inherit distutils eutils multilib
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=dev-python/wxpython-2.6"
+RDEPEND="=dev-python/wxpython-2.6*"
DEPEND="app-arch/unzip"
S=${WORKDIR}/${PN}
@@ -22,12 +22,12 @@ src_install() {
local destdir="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/"
dodir ${destdir}/bitmaps/{16,24}
- cp -R bitmaps ${D}/${destdir} || die "Failed to cp bitmaps"
+ cp -R bitmaps "${D}"/${destdir} || die "Failed to cp bitmaps"
distutils_src_install
#Windows-only setup script:
- rm ${D}/usr/bin/postinst.py
+ rm "${D}"/usr/bin/postinst.py
make_wrapper drpython "python ${destdir}drpython.py"
}