summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-26 14:31:56 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-26 14:31:56 +0000
commitafdb3c28820a2391b6f9c5703b0d6e326014364c (patch)
tree5d8c2c0f05f3d24b51d30ddae0f1150e79af7c89 /dev-python/empy/empy-3.3.ebuild
parentVersion bump, drop old (diff)
downloadhistorical-afdb3c28820a2391b6f9c5703b0d6e326014364c.tar.gz
historical-afdb3c28820a2391b6f9c5703b0d6e326014364c.tar.bz2
historical-afdb3c28820a2391b6f9c5703b0d6e326014364c.zip
Remove old.
Package-Manager: portage-2.2.15/cvs/Linux x86_64
Diffstat (limited to 'dev-python/empy/empy-3.3.ebuild')
-rw-r--r--dev-python/empy/empy-3.3.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/empy/empy-3.3.ebuild b/dev-python/empy/empy-3.3.ebuild
deleted file mode 100644
index a003efe795bc..000000000000
--- a/dev-python/empy/empy-3.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/empy/empy-3.3.ebuild,v 1.13 2010/03/28 17:31:31 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="A powerful and robust templating system for Python"
-HOMEPAGE="http://www.alcyone.com/software/empy/"
-SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-PYTHON_MODNAME="em.py"
-
-src_prepare() {
- distutils_src_prepare
- sed -e "s:/usr/local/bin/python:/usr/bin/python:g" -i em.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- ./test.sh "$(PYTHON)"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dodir /usr/bin
-
- create_symlink() {
- python_convert_shebangs $(python_get_version) "${ED}$(python_get_sitedir)/em.py"
- fperms 755 "$(python_get_sitedir)/em.py"
- dosym "$(python_get_sitedir)/em.py" "/usr/bin/em.py-${PYTHON_ABI}"
- }
- python_execute_function -q create_symlink
-
- python_generate_wrapper_scripts "${ED}usr/bin/em.py"
-
- if use doc; then
- dodir /usr/share/doc/"${PF}"/examples
- insinto /usr/share/doc/"${PF}"/examples
- doins sample.em sample.bench
- #3.3 has the html in this funny place. Fix in later version:
- dohtml doc/home/max/projects/empy/doc/em/*
- dohtml doc/home/max/projects/empy/doc/em.html
- dohtml doc/index.html
- fi
-}