summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-01 14:42:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-01 14:42:50 +0000
commitef7c2a12a8c88845489cd2a181008c08b0d50c23 (patch)
tree9d1835087b346c343ca9badefbaf5fd00467e4c2 /dev-python/enthoughtbase
parentnon-maintainer commit: version bump (bug #313593) (diff)
downloadhistorical-ef7c2a12a8c88845489cd2a181008c08b0d50c23.tar.gz
historical-ef7c2a12a8c88845489cd2a181008c08b0d50c23.tar.bz2
historical-ef7c2a12a8c88845489cd2a181008c08b0d50c23.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/enthoughtbase')
-rw-r--r--dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild b/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
deleted file mode 100644
index 3e316a3f2b7d..000000000000
--- a/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild,v 1.6 2010/02/28 10:47:17 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="EnthoughtBase"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Core packages for the Enthought Tool Suite"
-HOMEPAGE="http://code.enthought.com/projects/enthought_base.php"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-IUSE="doc examples"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-LICENSE="BSD LGPL-2"
-RDEPEND=""
-DEPEND="dev-python/setuptools
- doc? ( dev-python/setupdocs )"
-# tests would require circular deps
-# test? ( >=dev-python/nose-0.10.3
-# dev-python/traits
-# dev-python/etsdevtools )"
-RESTRICT_PYTHON_ABIS="3.*"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="enthought"
-
-src_prepare() {
- sed -i \
- -e "s/self.run_command('build_docs')/pass/" \
- -e '/setupdocs/d' \
- setup.py || die
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- "$(PYTHON -f)" setup.py build_docs --formats=html,pdf \
- || die "doc building failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- python_execute_function
-}
-
-src_install() {
- find "${S}" -name \*LICENSE.txt -delete
- distutils_src_install
- dodoc docs/*.txt
- insinto /usr/share/doc/${PF}
- if use doc; then
- doins -r build/docs/html || die
- doins build/docs/latex/*.pdf || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}