summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-24 21:22:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-24 21:22:00 +0000
commit62ab4e07363d1d7f635d124ccb2690aecdad7fc3 (patch)
tree13575d112fb66d79f87e8444331c6a28ac0198f5 /dev-python/git-python
parentDelete older ebuild. (diff)
downloadhistorical-62ab4e07363d1d7f635d124ccb2690aecdad7fc3.tar.gz
historical-62ab4e07363d1d7f635d124ccb2690aecdad7fc3.tar.bz2
historical-62ab4e07363d1d7f635d124ccb2690aecdad7fc3.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/ChangeLog8
-rw-r--r--dev-python/git-python/git-python-0.1.7.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/git-python/ChangeLog b/dev-python/git-python/ChangeLog
index d3b3027a2aa3..231b981fd8cb 100644
--- a/dev-python/git-python/ChangeLog
+++ b/dev-python/git-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/git-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.4 2010/03/17 16:49:57 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.5 2010/04/24 21:22:00 arfrever Exp $
+
+*git-python-0.1.7 (24 Apr 2010)
+
+ 24 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +git-python-0.1.7.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
17 Mar 2010; Sebastian Pipping <sping@gentoo.org> git-python-0.1.6.ebuild:
Propagate move of dev-util/git to dev-vcs/git
diff --git a/dev-python/git-python/git-python-0.1.7.ebuild b/dev-python/git-python/git-python-0.1.7.ebuild
new file mode 100644
index 000000000000..1b8c9a4915aa
--- /dev/null
+++ b/dev-python/git-python/git-python-0.1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.1.7.ebuild,v 1.1 2010/04/24 21:22:00 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="GitPython"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GitPython is a python library used to interact with Git repositories."
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="git"