summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-21 04:25:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-21 04:25:26 +0000
commit1b883a55b4526c6e0435c0a7f1d3a30bdc1dc74f (patch)
treeccd91217866c75b5ddf875176357a87e1cec2d8b /dev-python/h5py/h5py-1.2.1.ebuild
parentAdded dev-python/optik for removal in 30 days (diff)
downloadhistorical-1b883a55b4526c6e0435c0a7f1d3a30bdc1dc74f.tar.gz
historical-1b883a55b4526c6e0435c0a7f1d3a30bdc1dc74f.tar.bz2
historical-1b883a55b4526c6e0435c0a7f1d3a30bdc1dc74f.zip
Initial import to the main tree
Package-Manager: portage-2.2_rc41/cvs/Linux x86_64
Diffstat (limited to 'dev-python/h5py/h5py-1.2.1.ebuild')
-rw-r--r--dev-python/h5py/h5py-1.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/h5py/h5py-1.2.1.ebuild b/dev-python/h5py/h5py-1.2.1.ebuild
new file mode 100644
index 000000000000..853a92a30f91
--- /dev/null
+++ b/dev-python/h5py/h5py-1.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-1.2.1.ebuild,v 1.1 2009/09/21 04:25:26 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="A simple Python interface to HDF5 files."
+HOMEPAGE="http://h5py.alfven.org/"
+SRC_URI="http://h5py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sci-libs/hdf5-1.6.7
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ "${python}" setup.py test || die "test failed"
+}