summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-11-03 19:24:06 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-11-03 19:24:06 +0000
commitad045dfedfe32eb3eb74d6f1c405499f1bc742ad (patch)
tree8198dcabcce4b65c5578ef116431b9ee93b8299e /dev-python/lupy
parentadded examples (#72183) (diff)
downloadhistorical-ad045dfedfe32eb3eb74d6f1c405499f1bc742ad.tar.gz
historical-ad045dfedfe32eb3eb74d6f1c405499f1bc742ad.tar.bz2
historical-ad045dfedfe32eb3eb74d6f1c405499f1bc742ad.zip
added examples (#72183)
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-python/lupy')
-rw-r--r--dev-python/lupy/ChangeLog7
-rw-r--r--dev-python/lupy/files/digest-lupy-0.2.1-r11
-rw-r--r--dev-python/lupy/lupy-0.2.1-r1.ebuild28
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/lupy/ChangeLog b/dev-python/lupy/ChangeLog
index 22d0e083d066..cda586ac40e2 100644
--- a/dev-python/lupy/ChangeLog
+++ b/dev-python/lupy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/lupy
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lupy/ChangeLog,v 1.6 2005/02/07 05:00:39 fserb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lupy/ChangeLog,v 1.7 2005/11/03 19:22:44 liquidx Exp $
+
+*lupy-0.2.1-r1 (03 Nov 2005)
+
+ 03 Nov 2005; Alastair Tse <liquidx@gentoo.org> +lupy-0.2.1-r1.ebuild:
+ added examples (#72183)
07 Feb 2005; Fernando Serboncini <fserb@gentoo.org> lupy-0.1.5.5.1.ebuild:
stable on x86
diff --git a/dev-python/lupy/files/digest-lupy-0.2.1-r1 b/dev-python/lupy/files/digest-lupy-0.2.1-r1
new file mode 100644
index 000000000000..22d280935688
--- /dev/null
+++ b/dev-python/lupy/files/digest-lupy-0.2.1-r1
@@ -0,0 +1 @@
+MD5 515ea0b4aab8dd8299480cb9a0da6068 Lupy-0.2.1.tar.gz 52269
diff --git a/dev-python/lupy/lupy-0.2.1-r1.ebuild b/dev-python/lupy/lupy-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..e8c2113e2c10
--- /dev/null
+++ b/dev-python/lupy/lupy-0.2.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lupy/lupy-0.2.1-r1.ebuild,v 1.1 2005/11/03 19:22:44 liquidx Exp $
+
+inherit distutils
+
+MY_PN="Lupy"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Lupy is a is a full-text indexer and search engine written in Python."
+HOMEPAGE="http://www.divmod.org/Lupy/index.html"
+SRC_URI="mirror://sourceforge/lupy/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~s390 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/aesop
+ doins ${S}/examples/aesop/*
+}