summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-20 07:51:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-20 07:51:35 +0000
commit69bb49c04b70c4d75dd5b19cc5af90c5f8f4cd6e (patch)
tree6920eb2f6b497186120f5657d185c11ac846f2a3 /dev-python/pastescript
parentBump for 404549 (diff)
downloadhistorical-69bb49c04b70c4d75dd5b19cc5af90c5f8f4cd6e.tar.gz
historical-69bb49c04b70c4d75dd5b19cc5af90c5f8f4cd6e.tar.bz2
historical-69bb49c04b70c4d75dd5b19cc5af90c5f8f4cd6e.zip
Bump for 404547
Package-Manager: portage-2.2.0_alpha87/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/ChangeLog9
-rw-r--r--dev-python/pastescript/pastescript-1.7.5.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-python/pastescript/ChangeLog b/dev-python/pastescript/ChangeLog
index 1857d1cba174..c19e120f42fe 100644
--- a/dev-python/pastescript/ChangeLog
+++ b/dev-python/pastescript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pastescript
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.9 2010/06/27 22:59:32 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.10 2012/02/20 07:51:35 patrick Exp $
+
+*pastescript-1.7.5 (20 Feb 2012)
+
+ 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> +pastescript-1.7.5.ebuild:
+ Bump for 404547
27 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pastescript-1.7.3.ebuild:
diff --git a/dev-python/pastescript/pastescript-1.7.5.ebuild b/dev-python/pastescript/pastescript-1.7.5.ebuild
new file mode 100644
index 000000000000..1471d5192a34
--- /dev/null
+++ b/dev-python/pastescript/pastescript-1.7.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.5.ebuild,v 1.1 2012/02/20 07:51:35 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+#DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="PasteScript"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
+HOMEPAGE="http://pythonpaste.org/script/ http://pypi.python.org/pypi/PasteScript"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+RDEPEND="dev-python/cheetah
+ >=dev-python/paste-1.3
+ dev-python/pastedeploy
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/pygments dev-python/sphinx )"
+
+# Tests are broken.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="paste/script"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}