summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2004-06-27 14:58:17 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2004-06-27 14:58:17 +0000
commit410433946fbd5bd4709ea5a7825f9e68c59d7b99 (patch)
treea59f7065cf8d510a140cd06c1cb7f23415b32aa8 /dev-python/ply
parentinitial commit (diff)
downloadhistorical-410433946fbd5bd4709ea5a7825f9e68c59d7b99.tar.gz
historical-410433946fbd5bd4709ea5a7825f9e68c59d7b99.tar.bz2
historical-410433946fbd5bd4709ea5a7825f9e68c59d7b99.zip
Initial commit.
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/ChangeLog9
-rw-r--r--dev-python/ply/Manifest4
-rw-r--r--dev-python/ply/files/digest-ply-1.51
-rw-r--r--dev-python/ply/metadata.xml14
-rw-r--r--dev-python/ply/ply-1.5.ebuild22
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/ply/ChangeLog b/dev-python/ply/ChangeLog
new file mode 100644
index 000000000000..8176aac1005a
--- /dev/null
+++ b/dev-python/ply/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/ply
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.1 2004/06/27 14:58:17 lucass Exp $
+
+*ply-1.5 (27 Jun 2004)
+
+ 27 Jun 2004; Lukasz Strzygowski <lucass@gentoo.org> +ply-1.5.ebuild:
+ Initial commit. Thanks to Yann Ramin in bug #49932.
+
diff --git a/dev-python/ply/Manifest b/dev-python/ply/Manifest
new file mode 100644
index 000000000000..6d56cad32c62
--- /dev/null
+++ b/dev-python/ply/Manifest
@@ -0,0 +1,4 @@
+MD5 9a660c80d27c439eb5a908a5ddfcfeb1 ply-1.5.ebuild 574
+MD5 e9af3acc28740c46b168cfe48fc2c141 metadata.xml 666
+MD5 bdd7cb2247d088a7a2886e9ed2eb7e4d ChangeLog 351
+MD5 c599af08601e51fff11b9fd1193f2086 files/digest-ply-1.5 58
diff --git a/dev-python/ply/files/digest-ply-1.5 b/dev-python/ply/files/digest-ply-1.5
new file mode 100644
index 000000000000..dc7a064f8799
--- /dev/null
+++ b/dev-python/ply/files/digest-ply-1.5
@@ -0,0 +1 @@
+MD5 88549f0d9cf7ff6c62123e1f05a4f0d2 ply-1.5.tar.gz 69278
diff --git a/dev-python/ply/metadata.xml b/dev-python/ply/metadata.xml
new file mode 100644
index 000000000000..1b7d0e07991a
--- /dev/null
+++ b/dev-python/ply/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+PLY is a Python-only implementation of the popular compiler construction
+tools lex and yacc. The implementation borrows ideas from a number of
+previous efforts; most notably John Aycock's SPARK toolkit. However,
+the overall flavor of the implementation is more closely modeled after
+the C version of lex and yacc. The other significant feature of PLY is
+that it provides extensive input validation and error reporting--much
+more so than other Python parsing tools.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/ply/ply-1.5.ebuild b/dev-python/ply/ply-1.5.ebuild
new file mode 100644
index 000000000000..0c9abf721fcd
--- /dev/null
+++ b/dev-python/ply/ply-1.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-1.5.ebuild,v 1.1 2004/06/27 14:58:17 lucass Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="Python Lex-Yacc library"
+SRC_URI="http://systems.cs.uchicago.edu/ply/${P}.tar.gz"
+HOMEPAGE="http://systems.cs.uchicago.edu/ply/"
+DEPEND="virtual/python"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+src_install() {
+ distutils_src_install
+ dohtml doc/*
+ dodoc CHANGES TODO
+ cp -r example ${D}/usr/share/doc/${PF}
+}
+