summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-22 05:57:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-22 05:57:17 +0000
commit824fbefbb9eb81674315d51c1e0bcad821826fe4 (patch)
tree5334a182193981589917c6499105a6fa904bcfe2 /dev-python/pyode
parentuse ${PF} instead of ${P} for doc dir (diff)
downloadhistorical-824fbefbb9eb81674315d51c1e0bcad821826fe4.tar.gz
historical-824fbefbb9eb81674315d51c1e0bcad821826fe4.tar.bz2
historical-824fbefbb9eb81674315d51c1e0bcad821826fe4.zip
add ~amd64 #110067 for accelerator #110010 and add a sanity check to make sure the build/install worked
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'dev-python/pyode')
-rw-r--r--dev-python/pyode/Manifest18
-rw-r--r--dev-python/pyode/pyode-1.1.0.ebuild26
2 files changed, 32 insertions, 12 deletions
diff --git a/dev-python/pyode/Manifest b/dev-python/pyode/Manifest
index 7919d804eb6a..808e2fff1aed 100644
--- a/dev-python/pyode/Manifest
+++ b/dev-python/pyode/Manifest
@@ -1,7 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 dd98a30f3d3813ff3c3ada858875f26d ChangeLog 841
-MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 76cec8c1f6757e829c128897da993059 pyode-1.0.0.ebuild 627
-MD5 a5e44fcbcee1e5405d5950b0925bcbb3 pyode-1.1.0.ebuild 677
MD5 28319c1ee83741ae44d70c2d45f71178 files/digest-pyode-1.0.0 63
-MD5 7e9af3d258e2ec74950c8a970c37fcfe files/odepath.patch 720
MD5 4ec18c02e226fd64ce9e7121ed4e817b files/digest-pyode-1.1.0 64
+MD5 7e9af3d258e2ec74950c8a970c37fcfe files/odepath.patch 720
+MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 76cec8c1f6757e829c128897da993059 pyode-1.0.0.ebuild 627
+MD5 7c267e321cb1eb025694b0920c6ed596 pyode-1.1.0.ebuild 917
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDWdTRgIKl8Uu19MoRAoSDAJ9jxp7neZim6qDT4M/5AuwmzbY4GACfWAGK
+zCB/lG17TytI6DZg9fnXiOQ=
+=b4/O
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pyode/pyode-1.1.0.ebuild b/dev-python/pyode/pyode-1.1.0.ebuild
index c39b180ba483..c07c0053f6f4 100644
--- a/dev-python/pyode/pyode-1.1.0.ebuild
+++ b/dev-python/pyode/pyode-1.1.0.ebuild
@@ -1,26 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyode/pyode-1.1.0.ebuild,v 1.2 2005/08/04 15:05:35 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyode/pyode-1.1.0.ebuild,v 1.3 2005/10/22 05:57:17 vapier Exp $
inherit distutils
-MY_P="${P/pyode/PyODE}"
+MY_P=${P/pyode/PyODE}
DESCRIPTION="python bindings to the ode physics engine"
HOMEPAGE="http://pyode.sourceforge.net/"
SRC_URI="mirror://sourceforge/pyode/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="virtual/python
- >=dev-games/ode-0.5
- >=dev-python/pyrex-0.9.3"
+ >=dev-games/ode-0.5
+ >=dev-python/pyrex-0.9.3"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
- sed -i -e "s:#ODE_BASE = .*:ODE_BASE = '/usr/share/ode-0.5':" setup.py
+ cd "${S}"
+ sed -i \
+ -e "s:#ODE_BASE = .*:ODE_BASE = '/usr/share/ode-0.5':" \
+ setup.py || die
+}
+
+src_install() {
+ distutils_src_install
+ # The build system doesnt error if it fails to build
+ # the ode library so we need our own sanity check
+ [[ -z $(find "${D}" -name ode.so) ]] && die "failed to build/install :("
}