summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2003-12-07 00:59:52 +0000
committerChris PeBenito <pebenito@gentoo.org>2003-12-07 00:59:52 +0000
commitf4cd31e5ca74b4363b02e6af0d01634c23e1fe5c (patch)
tree69e0c8453c3d954436a75fb27f1024e2ad05c248 /dev-python/python-selinux/python-selinux-2.10.ebuild
parentmoved from app-misc to x11-misc, metadata.xml created (diff)
downloadhistorical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.tar.gz
historical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.tar.bz2
historical-f4cd31e5ca74b4363b02e6af0d01634c23e1fe5c.zip
add python eclass usage
Diffstat (limited to 'dev-python/python-selinux/python-selinux-2.10.ebuild')
-rw-r--r--dev-python/python-selinux/python-selinux-2.10.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/python-selinux/python-selinux-2.10.ebuild b/dev-python/python-selinux/python-selinux-2.10.ebuild
index a9a7e5982220..1c442c6632aa 100644
--- a/dev-python/python-selinux/python-selinux-2.10.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.10.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.10.ebuild,v 1.2 2003/12/06 23:44:01 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.10.ebuild,v 1.3 2003/12/07 00:59:49 pebenito Exp $
+
+inherit python
+python_version
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
@@ -24,10 +27,10 @@ src_unpack() {
src_compile() {
cd ${S}
einfo "Compiling selinux.so"
- gcc -fPIC -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lselinux || die
+ gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
}
src_install() {
- insinto /usr/lib/python2.2/site-packages
+ insinto /usr/lib/python${PYVER}/site-packages
doins selinux.so
}