summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2011-02-18 10:22:30 +0000
committerCédric Krier <cedk@gentoo.org>2011-02-18 10:22:30 +0000
commit00ee3fbc840c58a8d71ce6543aca1a14d7fd0f59 (patch)
tree868b0632497955c9d2748770e566050073e4ed3b /dev-python/pywebdav/pywebdav-0.9.4.1.ebuild
parentAdd Class-Accessor to DEPEND too (diff)
downloadhistorical-00ee3fbc840c58a8d71ce6543aca1a14d7fd0f59.tar.gz
historical-00ee3fbc840c58a8d71ce6543aca1a14d7fd0f59.tar.bz2
historical-00ee3fbc840c58a8d71ce6543aca1a14d7fd0f59.zip
Version bump
Package-Manager: portage-2.1.9.25/cvs/Linux i686
Diffstat (limited to 'dev-python/pywebdav/pywebdav-0.9.4.1.ebuild')
-rw-r--r--dev-python/pywebdav/pywebdav-0.9.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pywebdav/pywebdav-0.9.4.1.ebuild b/dev-python/pywebdav/pywebdav-0.9.4.1.ebuild
new file mode 100644
index 000000000000..3dcfb98403b3
--- /dev/null
+++ b/dev-python/pywebdav/pywebdav-0.9.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebdav/pywebdav-0.9.4.1.ebuild,v 1.1 2011/02/18 10:22:30 cedk Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P=${P/pywebdav/PyWebDAV}
+
+DESCRIPTION="WebDAV server written in Python"
+HOMEPAGE="http://code.google.com/p/pywebdav/ http://pypi.python.org/pypi/PyWebDAV"
+SRC_URI="http://pywebdav.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="DAV DAVServer"