summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 21:32:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 21:32:32 +0000
commit128cd842b2a4cd554f6da165cf23424fd8c9e8ce (patch)
treeba36f89dcc37423005009ad1c4d684691c4aa3a3 /dev-python/rdflib/rdflib-3.0.0.ebuild
parentMarked ppc/ppc64 stable for bug #319499. (diff)
downloadhistorical-128cd842b2a4cd554f6da165cf23424fd8c9e8ce.tar.gz
historical-128cd842b2a4cd554f6da165cf23424fd8c9e8ce.tar.bz2
historical-128cd842b2a4cd554f6da165cf23424fd8c9e8ce.zip
Version bump.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/rdflib/rdflib-3.0.0.ebuild')
-rw-r--r--dev-python/rdflib/rdflib-3.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rdflib/rdflib-3.0.0.ebuild b/dev-python/rdflib/rdflib-3.0.0.ebuild
new file mode 100644
index 000000000000..e49795cb873f
--- /dev/null
+++ b/dev-python/rdflib/rdflib-3.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.0.0.ebuild,v 1.1 2010/05/13 21:32:32 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="http://rdflib.net/ http://pypi.python.org/pypi/rdflib"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite zodb"
+
+RDEPEND="mysql? ( dev-python/mysql-python )
+ sqlite? (
+ >=dev-db/sqlite-3.3.13
+ || ( dev-python/pysqlite >=dev-lang/python-2.5 ) )
+ berkdb? ( sys-libs/db )
+ redland? ( dev-libs/redland-bindings[python] )
+ zodb? ( net-zope/zodb )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib)" "$(PYTHON)" run_tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}