summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-07 05:54:56 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-07 05:54:56 +0000
commit093f2189abbfb98286ef43d2a79cba3326875fd6 (patch)
tree1eb806fc65f687d7fcf9c770065f8f9044d76dd7 /dev-python/rhpxl/rhpxl-0.32.ebuild
parentBump. (diff)
downloadhistorical-093f2189abbfb98286ef43d2a79cba3326875fd6.tar.gz
historical-093f2189abbfb98286ef43d2a79cba3326875fd6.tar.bz2
historical-093f2189abbfb98286ef43d2a79cba3326875fd6.zip
Force on DDC for radeon driver, so we get valid modes.
Package-Manager: portage-2.1.1_rc1-r4
Diffstat (limited to 'dev-python/rhpxl/rhpxl-0.32.ebuild')
-rw-r--r--dev-python/rhpxl/rhpxl-0.32.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/rhpxl/rhpxl-0.32.ebuild b/dev-python/rhpxl/rhpxl-0.32.ebuild
index 78acac90f44d..3bae77f94345 100644
--- a/dev-python/rhpxl/rhpxl-0.32.ebuild
+++ b/dev-python/rhpxl/rhpxl-0.32.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/rhpxl-0.32.ebuild,v 1.1 2006/09/05 21:20:35 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/rhpxl-0.32.ebuild,v 1.2 2006/09/07 05:54:56 dberkholz Exp $
-inherit rpm
+inherit eutils rpm
# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
# tarball out of it
@@ -25,6 +25,12 @@ RDEPEND="dev-lang/python
DEPEND="${RDEPEND}
sys-devel/gettext"
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-use-radeon-ddc.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}