summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-04 11:48:34 +0000
committerJustin Lecher <jlec@gentoo.org>2013-06-04 11:48:34 +0000
commita9924d8eef65ce2ff705c04d76d86950a5eb6981 (patch)
treee8de61c57861e724ef7e764c1dd00ea706ffbebc /dev-python/simpy/simpy-2.3.1-r1.ebuild
parentMarked stable on AMD64 based on a report by Elijah "Armageddon" El Lazkani in... (diff)
downloadhistorical-a9924d8eef65ce2ff705c04d76d86950a5eb6981.tar.gz
historical-a9924d8eef65ce2ff705c04d76d86950a5eb6981.tar.bz2
historical-a9924d8eef65ce2ff705c04d76d86950a5eb6981.zip
dev-python/simpy: Bump to new python eclasses
Package-Manager: portage-2.2.0_alpha177/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'dev-python/simpy/simpy-2.3.1-r1.ebuild')
-rw-r--r--dev-python/simpy/simpy-2.3.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/simpy/simpy-2.3.1-r1.ebuild b/dev-python/simpy/simpy-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..38cb60021edc
--- /dev/null
+++ b/dev-python/simpy/simpy-2.3.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpy/simpy-2.3.1-r1.ebuild,v 1.1 2013/06/04 11:48:33 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="http://simpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/SimPy-2.3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ ${PYTHON} -c "import SimPy; SimPy.test()" || die
+}
+
+python_install_all() {
+ DOCS=( AUTHORS.txt CHANGES.txt README.txt )
+ if use doc; then
+ pushd docs > /dev/null || die
+ PYTHONPATH=.. emake html && HTML_DOCS=( docs/html/. docs/build/doctrees/. )
+ popd > /dev/null || die
+ fi
+
+ distutils-r1_python_install_all
+}