summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-12-04 19:03:40 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-12-04 19:03:40 +0000
commitb48387cf4b82b449bf5f0f8f515c9c48016fcb91 (patch)
tree6fe56d4718a5b288623bdde56276bf0ced468006 /dev-python/testoob/testoob-1.13.ebuild
parentStable on ppc64; bug #156872 (diff)
downloadhistorical-b48387cf4b82b449bf5f0f8f515c9c48016fcb91.tar.gz
historical-b48387cf4b82b449bf5f0f8f515c9c48016fcb91.tar.bz2
historical-b48387cf4b82b449bf5f0f8f515c9c48016fcb91.zip
Version bump, bug #157098. Removed src_unpack.
Package-Manager: portage-2.1.2_rc2-r3
Diffstat (limited to 'dev-python/testoob/testoob-1.13.ebuild')
-rw-r--r--dev-python/testoob/testoob-1.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/testoob/testoob-1.13.ebuild b/dev-python/testoob/testoob-1.13.ebuild
new file mode 100644
index 000000000000..0f72979c2ce6
--- /dev/null
+++ b/dev-python/testoob/testoob-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testoob/testoob-1.13.ebuild,v 1.1 2006/12/04 19:03:40 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Advanced Python testing framework"
+HOMEPAGE="http://testoob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/testoob/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="pdf threads"
+
+DEPEND="virtual/python"
+RDEPEND="${DEPEND}
+ dev-python/4suite
+ pdf? ( dev-python/reportlab )
+ threads? ( dev-python/twisted )"
+
+DOCS="docs/*"
+
+src_test() {
+ distutils_python_version
+ PATH="src/testoob:${PATH}" PYTHONPATH="src" \
+ "${python}" tests/alltests.py || die "alltests.py failed"
+}