summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-29 00:28:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-29 00:28:14 +0000
commit736f0b954e1d031663c67d012c5c682572d7c413 (patch)
tree770c1f2e81a58e43a03c609e62205eac145f986c /dev-python/wtforms
parenteapi=3; cleanup (diff)
downloadhistorical-736f0b954e1d031663c67d012c5c682572d7c413.tar.gz
historical-736f0b954e1d031663c67d012c5c682572d7c413.tar.bz2
historical-736f0b954e1d031663c67d012c5c682572d7c413.zip
Version bump.
Package-Manager: portage-2.2.0_alpha19_p6/cvs/Linux x86_64
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog10
-rw-r--r--dev-python/wtforms/Manifest4
-rw-r--r--dev-python/wtforms/wtforms-0.6.2.ebuild56
3 files changed, 67 insertions, 3 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index c5575f477085..95b76cec4ec1 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/wtforms
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.10 2010/10/23 14:33:31 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.11 2011/01/29 00:28:14 arfrever Exp $
+
+*wtforms-0.6.2 (29 Jan 2011)
+
+ 29 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +wtforms-0.6.2.ebuild:
+ Version bump.
23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-wtforms-0.6.ebuild:
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 2d2f637e9b3c..b134b8e45e26 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,4 +1,6 @@
DIST WTForms-0.6.1.zip 215659 RMD160 94ce74489e399424478933cf5475595f854e1182 SHA1 ef20687046aea8facf6f7b363cc6794efac11bac SHA256 776c9e15cc283a7454ff5c2a0407af38e7c6e7b81d0daa354bdfbf89bc73a061
+DIST WTForms-0.6.2.zip 216242 RMD160 ebd49183787302f0e4d0a022e692328cb240b077 SHA1 50ad72122b0583a0a19c03a8ee86b3cd2e6e0fde SHA256 fcb7e6426891de369317659abd813c34c77f76c8dcd619d59fc1f0d38c73df09
EBUILD wtforms-0.6.1.ebuild 1204 RMD160 955c6ea841499ac8d25743edb72947eee7ed8eab SHA1 ae3ce14664133858a61b921b68ecc6e5d631ab2c SHA256 65d77b72a70d9ebaf531c6a370568b0a3f498926cb67e2c87bbcef891398e6c6
-MISC ChangeLog 1389 RMD160 1e4767a6876473d5f516819458ab0bae87b03579 SHA1 c4b45c968171b507d2821c64336187cbc774d6f3 SHA256 9a832a27378f51f46011ae2976f85d24504e47549cd7362bf345fe2bf766ea77
+EBUILD wtforms-0.6.2.ebuild 1209 RMD160 e87b6ef2e1aea87da2ea6bfcbb629d15d5bca257 SHA1 95e310e975877e2ae5722852423cf57e49d8c4fd SHA256 13c326a1daa65bf8664b1d6bdef6947f657ac81fcbabf65152accb440d744c7e
+MISC ChangeLog 1534 RMD160 c6c9d56b99b09dd0fac64b83cdc6f80b5348e7a3 SHA1 925c5bd882ce148375e1d6a4a81056fe5cff7269 SHA256 dbed7144007a374ba841b1b009d7b51c247fcf756132c7b09ebcde3baa11a33b
MISC metadata.xml 259 RMD160 4b781a038008fac445e4154045f964b64ad59e75 SHA1 9809d89f3360f9f7537c2bb480d6bcbe942c6ea0 SHA256 0fb1da675767b69b5bd240d135effe2fc500e8b997a5f4eed212e5b26d027972
diff --git a/dev-python/wtforms/wtforms-0.6.2.ebuild b/dev-python/wtforms/wtforms-0.6.2.ebuild
new file mode 100644
index 000000000000..197cb35b689a
--- /dev/null
+++ b/dev-python/wtforms/wtforms-0.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-0.6.2.ebuild,v 1.1 2011/01/29 00:28:14 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_test() {
+ cd tests
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}