summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-02-20 16:11:15 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-02-20 16:11:15 +0000
commitee3fb5e9ee8edf3fdf75845002c463c8c56fc788 (patch)
tree3591e5c5964d3507073ab5e69cab1b2fc93be931 /dev-python
parentdropped ppc64 keyword by accident (diff)
downloadhistorical-ee3fb5e9ee8edf3fdf75845002c463c8c56fc788.tar.gz
historical-ee3fb5e9ee8edf3fdf75845002c463c8c56fc788.tar.bz2
historical-ee3fb5e9ee8edf3fdf75845002c463c8c56fc788.zip
version bump
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog8
-rw-r--r--dev-python/PyQt/PyQt-3.13-r1.ebuild62
-rw-r--r--dev-python/PyQt/PyQt-3.14.ebuild62
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.13-r11
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.141
5 files changed, 133 insertions, 1 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index cf0c3eece451..ffb0206bf889 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.51 2005/02/08 05:46:02 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.52 2005/02/20 16:11:15 carlo Exp $
+
+*PyQt-3.13-r1 (20 Feb 2005)
+
+ 20 Feb 2005; Carsten Lohrke <carlo@gentoo.org> +PyQt-3.13-r1.ebuild,
+ +PyQt-3.14.ebuild:
+ version bump
07 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org> PyQt-3.13.ebuild:
Multilib fix for python.
diff --git a/dev-python/PyQt/PyQt-3.13-r1.ebuild b/dev-python/PyQt/PyQt-3.13-r1.ebuild
new file mode 100644
index 000000000000..fb8da9817fd2
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.13-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.13-r1.ebuild,v 1.1 2005/02/20 16:11:15 carlo Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-3.10.2
+ <dev-python/qscintilla-1.6"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
+ -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
+ use debug && myconf="${myconf} -u"
+ has distcc ${FEATURES} || myconf="${myconf} -c"
+
+ if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
+ echo ""
+ einfo "Low on memory?! Use distcc or get a coffee. :)"
+ echo ""
+ fi
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ if use doc ; then
+ dohtml doc/PyQt.html
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/PyQt-3.14.ebuild b/dev-python/PyQt/PyQt-3.14.ebuild
new file mode 100644
index 000000000000..5a871bd4fbf0
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.ebuild,v 1.1 2005/02/20 16:11:15 carlo Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/PyQt/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc -alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-4.2
+ <dev-python/qscintilla-1.6"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin \
+ -v /usr/share/sip -n /usr/include -o /usr/$(get_libdir)"
+ use debug && myconf="${myconf} -u"
+ has distcc ${FEATURES} || myconf="${myconf} -c"
+
+ if [ "$(echo $(free -m | grep Mem) | cut -d' ' -f2)" -lt "257" ] ; then
+ echo ""
+ einfo "Low on memory?! Use distcc or get a coffee. :)"
+ echo ""
+ fi
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ if use doc ; then
+ dohtml doc/PyQt.html
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.13-r1 b/dev-python/PyQt/files/digest-PyQt-3.13-r1
new file mode 100644
index 000000000000..c64660b67669
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.13-r1
@@ -0,0 +1 @@
+MD5 a4145b39742a4d9df9b6bf06495f75f5 PyQt-x11-gpl-3.13.tar.gz 763066
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14 b/dev-python/PyQt/files/digest-PyQt-3.14
new file mode 100644
index 000000000000..7b817feb77a1
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.14
@@ -0,0 +1 @@
+MD5 a63f0a9e2bd84a110ecbaf6cdf1d956f PyQt-x11-gpl-3.14.tar.gz 782085