summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-19 10:55:27 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-19 10:55:27 +0000
commit713f2d0d3f7f80754105876e8ee5b85bfc18efee (patch)
treeed8d40ed73dac3f7ee3dabbff447ccd80d34a28d /dev-ruby/activemodel
parentFix bugs #390845 and #386127 (diff)
downloadhistorical-713f2d0d3f7f80754105876e8ee5b85bfc18efee.tar.gz
historical-713f2d0d3f7f80754105876e8ee5b85bfc18efee.tar.bz2
historical-713f2d0d3f7f80754105876e8ee5b85bfc18efee.zip
Version bump for Rails 3.0.11.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.11.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 29ab7a67408c..a23fb14151e9 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.15 2011/10/05 17:59:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.16 2011/11/19 10:55:27 graaff Exp $
+
+*activemodel-3.0.11 (19 Nov 2011)
+
+ 19 Nov 2011; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.11.ebuild:
+ Version bump for Rails 3.0.11.
05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -activemodel-3.0.7.ebuild,
-activemodel-3.0.9.ebuild:
diff --git a/dev-ruby/activemodel/activemodel-3.0.11.ebuild b/dev-ruby/activemodel/activemodel-3.0.11.ebuild
new file mode 100644
index 000000000000..6271c8374781
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.11.ebuild,v 1.1 2011/11/19 10:55:27 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}