summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2005-01-04 11:54:52 +0000
committerMichael Kohl <citizen428@gentoo.org>2005-01-04 11:54:52 +0000
commit0e8e5c91600f9560a142bd9b2555505cfc30f388 (patch)
treebe95970808c64cba2ecded355270f91cca4e3fc6 /dev-ruby/canny
parentRemoved --proxy-timeout argument, fixes bug #57732. (diff)
downloadhistorical-0e8e5c91600f9560a142bd9b2555505cfc30f388.tar.gz
historical-0e8e5c91600f9560a142bd9b2555505cfc30f388.tar.bz2
historical-0e8e5c91600f9560a142bd9b2555505cfc30f388.zip
Initial import. Ebuild submitted by pyon <gentoo@pyon.net>, closing bug #67053
Diffstat (limited to 'dev-ruby/canny')
-rw-r--r--dev-ruby/canny/ChangeLog7
-rw-r--r--dev-ruby/canny/Manifest14
-rw-r--r--dev-ruby/canny/canny-0.1.0.ebuild29
-rw-r--r--dev-ruby/canny/files/digest-canny-0.1.01
-rw-r--r--dev-ruby/canny/metadata.xml5
5 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/canny/ChangeLog b/dev-ruby/canny/ChangeLog
new file mode 100644
index 000000000000..43eccc908981
--- /dev/null
+++ b/dev-ruby/canny/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-ruby/canny
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/canny/ChangeLog,v 1.1 2005/01/04 11:54:52 citizen428 Exp $
+
+ 04 Jan 2005; Michael Kohl <citizen428@gentoo.org> +metadata.xml:
+ Initial import. Ebuild submitted by pyon <gentoo@pyon.net>, closing bug #67053
+
diff --git a/dev-ruby/canny/Manifest b/dev-ruby/canny/Manifest
new file mode 100644
index 000000000000..71355330fcc3
--- /dev/null
+++ b/dev-ruby/canny/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 1561e69d0ad9558b143eb0736529017e canny-0.1.0.ebuild 796
+MD5 ebd2e45000c1bb76618f45e29b3c532a ChangeLog 354
+MD5 b522b82d2c47bc548a6607f0f577ab5e metadata.xml 158
+MD5 b5c80d49f9702f332ac9c41904ad1e0e files/digest-canny-0.1.0 62
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFB2oQV/UDVUK2NELYRAlckAJ9uXSRAnXYnn5Auzo9SUPPtFhjrqwCfUxyU
+mx/NJuoKAkoHrcETM1pzLkM=
+=NnjS
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/canny/canny-0.1.0.ebuild b/dev-ruby/canny/canny-0.1.0.ebuild
new file mode 100644
index 000000000000..ea53bdfcc4a2
--- /dev/null
+++ b/dev-ruby/canny/canny-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/canny/canny-0.1.0.ebuild,v 1.1 2005/01/04 11:54:52 citizen428 Exp $
+
+inherit ruby
+
+IUSE=""
+USE_RUBY="any"
+
+DESCRIPTION="Canny is a template library for Ruby."
+HOMEPAGE="http://canny.sourceforge.net/"
+SRC_URI="mirror://sourceforge/canny/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND="virtual/ruby"
+
+src_compile() {
+ ruby setup.rb config || die "setup.rb config failed"
+ ruby setup.rb setup || die "setup.rb setup failed"
+}
+
+src_install() {
+ ruby setup.rb config --prefix=${D}/usr || die "setup.rb config failed"
+ ruby setup.rb install || die "setup.rb install failed"
+ dodoc COPYING ChangeLog README* example.rb templates/*
+}
diff --git a/dev-ruby/canny/files/digest-canny-0.1.0 b/dev-ruby/canny/files/digest-canny-0.1.0
new file mode 100644
index 000000000000..bbeb0ca92ece
--- /dev/null
+++ b/dev-ruby/canny/files/digest-canny-0.1.0
@@ -0,0 +1 @@
+MD5 ade3ca6f25aab1b6b5d482df93045b8e canny-0.1.0.tar.gz 25868
diff --git a/dev-ruby/canny/metadata.xml b/dev-ruby/canny/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/canny/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>