summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:40:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:40:38 +0000
commitebb08519b8c94acbd74824a8e31429832c926fc1 (patch)
treec222cdbf72cd8b1edb9733464881850e42fed6e9 /dev-ruby/haml
parentDrop ruby19 to allow stabilization. (diff)
downloadhistorical-ebb08519b8c94acbd74824a8e31429832c926fc1.tar.gz
historical-ebb08519b8c94acbd74824a8e31429832c926fc1.tar.bz2
historical-ebb08519b8c94acbd74824a8e31429832c926fc1.zip
Cleanup old versions, use new syntax.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog6
-rw-r--r--dev-ruby/haml/haml-2.2.23.ebuild44
-rw-r--r--dev-ruby/haml/haml-2.2.24.ebuild13
3 files changed, 15 insertions, 48 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index b18c4fc1a890..9a15e6bee28f 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.42 2010/04/30 08:19:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.43 2010/05/22 13:28:36 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> -haml-2.2.23.ebuild,
+ haml-2.2.24.ebuild:
+ Cleanup old versions, use new syntax.
*haml-2.2.24 (30 Apr 2010)
diff --git a/dev-ruby/haml/haml-2.2.23.ebuild b/dev-ruby/haml/haml-2.2.23.ebuild
deleted file mode 100644
index b40e20ee59b7..000000000000
--- a/dev-ruby/haml/haml-2.2.23.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.23.ebuild,v 1.1 2010/04/27 05:54:53 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-inherit ruby-fakegem
-
-DESCRIPTION="HAML - a ruby web page templating engine"
-HOMEPAGE="http://haml.hamptoncatlin.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-# TODO: haml has some emacs modes that it could be installing, in case
-IUSE=""
-
-all_ruby_prepare() {
- sed -i -e '/haml.gemspec/,/Task\[:package\]/s:^:#:' "${S}"/Rakefile
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- # This is needed otherwise it fails at runtime
- ruby_fakegem_doins VERSION VERSION_NAME
-}
-
-# The html engine requires hpricot
-ruby_add_rdepend dev-ruby/hpricot
-
-# It could use merb during testing as well, but it's not mandatory
-ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/actionpack"
-ruby_add_bdepend doc "dev-ruby/yard dev-ruby/maruku"
diff --git a/dev-ruby/haml/haml-2.2.24.ebuild b/dev-ruby/haml/haml-2.2.24.ebuild
index 3213f582e6fb..02d8399d7f03 100644
--- a/dev-ruby/haml/haml-2.2.24.ebuild
+++ b/dev-ruby/haml/haml-2.2.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.24.ebuild,v 1.1 2010/04/30 08:19:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.24.ebuild,v 1.2 2010/05/22 13:28:36 flameeyes Exp $
EAPI=2
@@ -40,5 +40,12 @@ each_ruby_install() {
ruby_add_rdepend dev-ruby/hpricot
# It could use merb during testing as well, but it's not mandatory
-ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/actionpack"
-ruby_add_bdepend doc "dev-ruby/yard dev-ruby/maruku"
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/actionpack
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"