summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:17:54 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:17:54 +0000
commit682f6b40aa02611430138e650a6e4f8075aaee1e (patch)
tree8eea9794bb8ee9b2959741cd607485c656c463c3 /dev-ruby/optparse
parentA=-fix, try->die, tab-fixes, stylefixes, ... (diff)
downloadhistorical-682f6b40aa02611430138e650a6e4f8075aaee1e.tar.gz
historical-682f6b40aa02611430138e650a6e4f8075aaee1e.tar.bz2
historical-682f6b40aa02611430138e650a6e4f8075aaee1e.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-ruby/optparse')
-rw-r--r--dev-ruby/optparse/optparse-0.7.5.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-ruby/optparse/optparse-0.7.5.ebuild b/dev-ruby/optparse/optparse-0.7.5.ebuild
index 345c8ae45073..630142db5ecb 100644
--- a/dev-ruby/optparse/optparse-0.7.5.ebuild
+++ b/dev-ruby/optparse/optparse-0.7.5.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/optparse/optparse-0.7.5.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/optparse/optparse-0.7.5.ebuild,v 1.2 2001/11/10 12:17:54 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Yet another option parser for Ruby"
-SRC_URI=" http://member.nifty.ne.jp/nokada/archive/${A}"
+SRC_URI=" http://member.nifty.ne.jp/nokada/archive/${P}.tar.gz"
HOMEPAGE=" http://member.nifty.ne.jp/nokada/ruby.html"
DEPEND=">=dev-lang/ruby-1.6.1"
#src_compile() {
-# cd ${S}
-# try ruby setup.rb config --without=amstd
-# try ruby setup.rb setup
+# ruby setup.rb config --without=amstd || die
+# ruby setup.rb setup || die
#}
src_install () {
- cd ${S}
- insinto /usr/lib/ruby/site_ruby/1.6
- doins optparse.rb
+ insinto /usr/lib/ruby/site_ruby/1.6
+ doins optparse.rb
- insinto /usr/lib/ruby/site_ruby/1.6/optparse
- doins optparse/*
+ insinto /usr/lib/ruby/site_ruby/1.6/optparse
+ doins optparse/*
}