summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
commite69595df3ba25a83023a2a753982793c8ac6c4fb (patch)
tree255e97c312932427268fe5f8efcd6b52c63870ff /dev-ruby
parentRemove old version. (diff)
downloadhistorical-e69595df3ba25a83023a2a753982793c8ac6c4fb.tar.gz
historical-e69595df3ba25a83023a2a753982793c8ac6c4fb.tar.bz2
historical-e69595df3ba25a83023a2a753982793c8ac6c4fb.zip
Revision bump to create stable candidate.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/locale/ChangeLog8
-rw-r--r--dev-ruby/locale/locale-2.0.5-r2.ebuild4
-rw-r--r--dev-ruby/locale/locale-2.0.5-r3.ebuild46
-rw-r--r--dev-ruby/ruby-gettext/ChangeLog9
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild4
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild58
6 files changed, 123 insertions, 6 deletions
diff --git a/dev-ruby/locale/ChangeLog b/dev-ruby/locale/ChangeLog
index 524330e711be..07fe4fb4a298 100644
--- a/dev-ruby/locale/ChangeLog
+++ b/dev-ruby/locale/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/locale
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.25 2011/09/28 17:46:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.26 2011/09/28 17:48:24 graaff Exp $
+
+*locale-2.0.5-r3 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> locale-2.0.5-r2.ebuild,
+ +locale-2.0.5-r3.ebuild:
+ Revision bump to create stable candidate.
28 Sep 2011; Hans de Graaff <graaff@gentoo.org> -locale-2.0.5-r1.ebuild:
Remove old version.
diff --git a/dev-ruby/locale/locale-2.0.5-r2.ebuild b/dev-ruby/locale/locale-2.0.5-r2.ebuild
index b3729db727c6..eeaf0d34c0d0 100644
--- a/dev-ruby/locale/locale-2.0.5-r2.ebuild
+++ b/dev-ruby/locale/locale-2.0.5-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r2.ebuild,v 1.2 2011/07/20 10:04:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r2.ebuild,v 1.3 2011/09/28 17:48:24 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby ree18"
+USE_RUBY="ruby18 jruby ree18"
RUBY_FAKEGEM_TASK_DOC="rerdoc"
RUBY_FAKEGEM_DOCDIR="doc"
diff --git a/dev-ruby/locale/locale-2.0.5-r3.ebuild b/dev-ruby/locale/locale-2.0.5-r3.ebuild
new file mode 100644
index 000000000000..56b65f05a49c
--- /dev/null
+++ b/dev-ruby/locale/locale-2.0.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.5-r3.ebuild,v 1.1 2011/09/28 17:48:24 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization."
+HOMEPAGE="http://locale.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( || ( virtual/ruby-test-unit dev-ruby/test-unit:2 ) )"
+
+RUBY_PATCHES=( "${FILESDIR}/${PN}-language-fixes.patch" )
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove broken test. It's not clear if the test or code is
+ # broken... https://github.com/mutoh/locale/issues/2
+ rm test/test_detect_general.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}
diff --git a/dev-ruby/ruby-gettext/ChangeLog b/dev-ruby/ruby-gettext/ChangeLog
index ab8c257f2803..7956e39dfa0e 100644
--- a/dev-ruby/ruby-gettext/ChangeLog
+++ b/dev-ruby/ruby-gettext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-gettext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ChangeLog,v 1.72 2011/01/16 08:53:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ChangeLog,v 1.73 2011/09/28 17:51:28 graaff Exp $
+
+*ruby-gettext-2.1.0_p20100728-r2 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org>
+ ruby-gettext-2.1.0_p20100728-r1.ebuild,
+ +ruby-gettext-2.1.0_p20100728-r2.ebuild:
+ Revision bump to create stable candidate.
16 Jan 2011; Hans de Graaff <graaff@gentoo.org>
-ruby-gettext-1.93.0.ebuild, -ruby-gettext-2.1.0-r1.ebuild:
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
index 8fe0fb9493ff..07bbda40fd3c 100644
--- a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
+++ b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild,v 1.3 2011/01/10 18:08:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild,v 1.4 2011/09/28 17:51:28 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby ree18"
+USE_RUBY="ruby18 jruby ree18"
RUBY_FAKEGEM_NAME="${PN/ruby-/}"
RUBY_FAKEGEM_VERSION="${PV%_*}"
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild
new file mode 100644
index 000000000000..69ac93cf32e7
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild,v 1.1 2011/09/28 17:51:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog ChangeLog-1 NEWS-1 README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://www.yotabanana.com/hiki/ruby-gettext.html"
+SRC_URI="http://dev.a3li.li/gentoo/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-macos"
+IUSE=""
+SLOT="0"
+LICENSE="Ruby"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5"
+
+RDEPEND="${RDEPEND}
+ sys-devel/gettext"
+DEPEND="${DEPEND}
+ sys-devel/gettext"
+
+ruby_add_bdepend "test? ( || ( virtual/ruby-test-unit dev-ruby/test-unit:2 ) )"
+
+all_ruby_prepare() {
+ # Allison 2.0.3 produces illegal HTML which markaby doesn't like.
+ sed -i '/allison/d' Rakefile || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ pushd test
+ ${RUBY} -S rake test || die "tests failed"
+ popd
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}