summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-03 16:10:41 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-03 16:10:41 +0000
commitf1d732e452438f9f8571a1c80fd94e4634639f5a (patch)
treed46aad92118236f6442029f94ea3b1eb2f1b3e47 /dev-ruby
parentVersion bump (diff)
downloadhistorical-f1d732e452438f9f8571a1c80fd94e4634639f5a.tar.gz
historical-f1d732e452438f9f8571a1c80fd94e4634639f5a.tar.bz2
historical-f1d732e452438f9f8571a1c80fd94e4634639f5a.zip
Initial import for Rails 3.0.3.
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog10
-rw-r--r--dev-ruby/activemodel/Manifest14
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.3.ebuild41
-rw-r--r--dev-ruby/activemodel/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
new file mode 100644
index 000000000000..893677605059
--- /dev/null
+++ b/dev-ruby/activemodel/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/activemodel
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.1 2010/12/03 16:10:41 graaff Exp $
+
+*activemodel-3.0.3 (03 Dec 2010)
+
+ 03 Dec 2010; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.3.ebuild,
+ +metadata.xml:
+ Initial import for Rails 3.0.3.
+
diff --git a/dev-ruby/activemodel/Manifest b/dev-ruby/activemodel/Manifest
new file mode 100644
index 000000000000..3c1630a55889
--- /dev/null
+++ b/dev-ruby/activemodel/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST rails-3.0.3.tgz 3471838 RMD160 ea484cd69bb938753fa35b19db0717a6b1e11663 SHA1 e5b66b4eee9e263305f1013929cb0662bd63c75b SHA256 b29efe183c54676ddd3f6195e60b446dc75f61e0c7b311186b2b876c43bd9f0c
+EBUILD activemodel-3.0.3.ebuild 1197 RMD160 ac20942135c624623febd11fe5574f9051ea7207 SHA1 5dc2b17470895f5403eda13f10d63877cef5d89b SHA256 802c76a9e2d7149a5bfc59cfbe90eb520be8137c5ce3505349dc9387c826f2bc
+MISC ChangeLog 376 RMD160 fbc12bc562f2d94a2256c76bb5832dc6b44f75dd SHA1 3c70396a153937307eaf5fc9faf038279e297ffb SHA256 fc6212be890f4e74d5f6b101004b32b2a74af82d878fdaeebce422d5d1065b49
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iF4EAREIAAYFAkz5Fo8ACgkQppaJjIURYXJqlAD/ZX0uzwPwZ1Je0du91Dz1T+pD
+e3qomO6v5dlJhfAGIaQA/AgzjIyu37nhnLgQpJSHXaRIac6wY/sWbChCf6j/xo0Q
+=oOWu
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/activemodel/activemodel-3.0.3.ebuild b/dev-ruby/activemodel/activemodel-3.0.3.ebuild
new file mode 100644
index 000000000000..1a9e2b0a4dd4
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.3.ebuild,v 1.1 2010/12/03 16:10:41 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+S="${WORKDIR}/rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.4.1:0.4"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activemodel/metadata.xml b/dev-ruby/activemodel/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/activemodel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>