summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-27 02:01:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-27 02:01:12 +0000
commitb0996c5dbb3195eacacc8bfb7ab0ef52baa5532f (patch)
treecdaccdf6594c6bc52a1e6c9dd676bde75fcfd15c /dev-texlive/texlive-context
parentsys-apps/chpax: Masked for removal in 30 days. Bug #365825 (diff)
downloadhistorical-b0996c5dbb3195eacacc8bfb7ab0ef52baa5532f.tar.gz
historical-b0996c5dbb3195eacacc8bfb7ab0ef52baa5532f.tar.bz2
historical-b0996c5dbb3195eacacc8bfb7ab0ef52baa5532f.zip
Bump to TeX Live 2012.
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'dev-texlive/texlive-context')
-rw-r--r--dev-texlive/texlive-context/ChangeLog8
-rw-r--r--dev-texlive/texlive-context/texlive-context-2012.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-texlive/texlive-context/ChangeLog b/dev-texlive/texlive-context/ChangeLog
index 9fd4748796fd..f25f0157d532 100644
--- a/dev-texlive/texlive-context/ChangeLog
+++ b/dev-texlive/texlive-context/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-texlive/texlive-context
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.58 2012/05/29 17:33:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.59 2012/07/27 01:29:32 aballier Exp $
+
+*texlive-context-2012 (27 Jul 2012)
+
+ 27 Jul 2012; Alexis Ballier <aballier@gentoo.org>
+ +texlive-context-2012.ebuild:
+ Bump to TeX Live 2012.
29 May 2012; Alexis Ballier <aballier@gentoo.org>
-texlive-context-2010-r1.ebuild, -files/luatools.patch:
diff --git a/dev-texlive/texlive-context/texlive-context-2012.ebuild b/dev-texlive/texlive-context/texlive-context-2012.ebuild
new file mode 100644
index 000000000000..df2b7f7271a8
--- /dev/null
+++ b/dev-texlive/texlive-context/texlive-context-2012.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/texlive-context-2012.ebuild,v 1.1 2012/07/27 01:29:32 aballier Exp $
+
+EAPI="4"
+
+TEXLIVE_MODULE_CONTENTS="context jmn lmextra context-account context-algorithmic context-bnf context-chromato context-construction-plan context-degrade context-filter context-fixme context-french context-fullpage context-games context-gantt context-gnuplot context-letter context-lettrine context-lilypond context-mathsets context-notes-zh-cn context-rst context-ruby context-simplefonts context-simpleslides context-typearea context-typescripts context-vim collection-context
+"
+TEXLIVE_MODULE_DOC_CONTENTS="context.doc context-account.doc context-bnf.doc context-chromato.doc context-construction-plan.doc context-degrade.doc context-filter.doc context-fixme.doc context-french.doc context-fullpage.doc context-games.doc context-gantt.doc context-gnuplot.doc context-letter.doc context-lettrine.doc context-lilypond.doc context-mathsets.doc context-notes-zh-cn.doc context-rst.doc context-ruby.doc context-simplefonts.doc context-simpleslides.doc context-typearea.doc context-typescripts.doc context-vim.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="context-fixme.source "
+inherit texlive-module
+DESCRIPTION="TeXLive ConTeXt format"
+
+LICENSE="GPL-2 as-is BSD GPL-1 GPL-2 public-domain "
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2012
+>=dev-texlive/texlive-latex-2010
+!<dev-texlive/texlive-latex-2010
+>=app-text/texlive-core-2010[xetex]
+>=dev-texlive/texlive-metapost-2010
+"
+RDEPEND="${DEPEND} dev-lang/ruby
+"
+TL_CONTEXT_UNIX_STUBS="context luatools mtxrun texexec texmfstart"
+
+TEXLIVE_MODULE_BINSCRIPTS="
+ texmf-dist/scripts/context/ruby/ctxtools.rb
+ texmf-dist/scripts/context/ruby/pstopdf.rb
+ texmf-dist/scripts/context/ruby/rlxtools.rb
+"
+
+for i in ${TL_CONTEXT_UNIX_STUBS} ; do
+TEXLIVE_MODULE_BINSCRIPTS="${TEXLIVE_MODULE_BINSCRIPTS} texmf-dist/scripts/context/stubs/unix/$i"
+done
+
+# This small hack is needed in order to have a sane upgrade path:
+# the new TeX Live 2009 metapost produces this file but it is not recorded in
+# any package; when running fmtutil (like texmf-update does) this file will be
+# created and cause collisions.
+
+pkg_setup() {
+ if [ -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log" ]; then
+ einfo "Removing ${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ rm -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ fi
+}
+
+# These comes without +x bit set...
+src_prepare() {
+ chmod +x texmf-dist/scripts/context/ruby/ctxtools.rb \
+ texmf-dist/scripts/context/ruby/pstopdf.rb \
+ texmf-dist/scripts/context/ruby/rlxtools.rb
+}
+
+TL_MODULE_INFORMATION="For using ConTeXt mkII simply use 'texexec' to generate
+your documents.
+If you plan to use mkIV and its 'context' command to generate your documents,
+you have to run 'luatools --generate' as normal user before first use.
+
+More information and advanced options on:
+http://wiki.contextgarden.net/TeX_Live_2011"