summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-21 15:30:09 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-21 15:30:09 +0000
commit4e10fb2945749b59dfd3e43bfa4183c2e542be92 (patch)
tree0ce2d9ab48d5d62594a60f5edd401f9e8fb74ba3 /dev-util/ccache/ccache-3.1.9-r4.ebuild
parentStable for sparc, wrt bug #531582 (diff)
downloadhistorical-4e10fb2945749b59dfd3e43bfa4183c2e542be92.tar.gz
historical-4e10fb2945749b59dfd3e43bfa4183c2e542be92.tar.bz2
historical-4e10fb2945749b59dfd3e43bfa4183c2e542be92.zip
ccache-config: Source /lib/gentoo/functions.sh, bug 504380.
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-util/ccache/ccache-3.1.9-r4.ebuild')
-rw-r--r--dev-util/ccache/ccache-3.1.9-r4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-3.1.9-r4.ebuild b/dev-util/ccache/ccache-3.1.9-r4.ebuild
new file mode 100644
index 000000000000..9e2876c69036
--- /dev/null
+++ b/dev-util/ccache/ccache-3.1.9-r4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.9-r4.ebuild,v 1.1 2014/12/21 15:30:06 floppym Exp $
+
+EAPI="4"
+
+inherit multilib eutils readme.gentoo
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ sys-apps/gentoo-functions"
+
+src_prepare() {
+ # make sure we always use system zlib
+ rm -rf zlib
+ epatch "${FILESDIR}"/${PN}-3.1.7-no-perl.patch #421609
+ epatch "${FILESDIR}"/${P}-test-gcc-4.8.patch #461966
+ sed \
+ -e "/^LIBDIR=/s:lib:$(get_libdir):" \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_install() {
+ default
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin ccache-config
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+${EPREFIX}/usr/$(get_libdir)/ccache/bin to the beginning of your path, before ${EPREFIX}usr/bin.
+Portage 2.0.46-r11+ will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} ]] ; then
+ "${EROOT}"/usr/bin/ccache-config --remove-links
+ "${EROOT}"/usr/bin/ccache-config --remove-links ${CHOST}
+ fi
+}
+
+pkg_postinst() {
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ "${EROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${EROOT}/usr/$(get_libdir)/ccache/bin/${CHOST}-cc"
+ [[ -d "${EROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -rf "${EROOT}/usr/$(get_libdir)/ccache.backup"
+
+ readme.gentoo_print_elog
+}