summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRemi Cardona <remi@gentoo.org>2009-05-27 11:02:05 +0000
committerRemi Cardona <remi@gentoo.org>2009-05-27 11:02:05 +0000
commitf46e4de6250368fa0a0b0c83acb241b9b9eebaac (patch)
treec75f7d3a02784019ad93dea909c3656ed6f3ad43 /dev-util/sysprof
parentstable x86, bug 271132 (diff)
downloadhistorical-f46e4de6250368fa0a0b0c83acb241b9b9eebaac.tar.gz
historical-f46e4de6250368fa0a0b0c83acb241b9b9eebaac.tar.bz2
historical-f46e4de6250368fa0a0b0c83acb241b9b9eebaac.zip
dev-util/sysprof: fix missing depmod in pkg_postinst which is done by the linux-mod eclass: modprobe is now able to see sysprof_module
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/ChangeLog8
-rw-r--r--dev-util/sysprof/Manifest3
-rw-r--r--dev-util/sysprof/sysprof-1.0.12-r1.ebuild56
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-util/sysprof/ChangeLog b/dev-util/sysprof/ChangeLog
index 0fe102241620..9ed74f77e56d 100644
--- a/dev-util/sysprof/ChangeLog
+++ b/dev-util/sysprof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/sysprof
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.14 2009/01/26 03:21:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/ChangeLog,v 1.15 2009/05/27 11:02:05 remi Exp $
+
+*sysprof-1.0.12-r1 (27 May 2009)
+
+ 27 May 2009; Rémi Cardona <remi@gentoo.org> +sysprof-1.0.12-r1.ebuild:
+ fix missing depmod in pkg_postinst which is done by the linux-mod eclass:
+ modprobe is now able to see sysprof_module
26 Jan 2009; Mart Raudsepp <leio@gentoo.org> sysprof-1.0.12.ebuild:
Add einfo about frame pointers and the lack of them affecting sysprof
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 98b2836d4c16..9e533d42374a 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,4 +1,5 @@
DIST sysprof-1.0.12.tar.gz 140946 RMD160 670fdf57bade273bc8ab62a7ecc8af3b3e07b4a4 SHA1 c5fae3caa6c7e4b7d1aa639dd8412fcb51d2cc8f SHA256 bf2e8eee6b7170eda13f1796b23b3f33170fa598652f36f8cc94eb93600b1f38
+EBUILD sysprof-1.0.12-r1.ebuild 1872 RMD160 23def2082483ac35f6196ed2bac6d1fb5bef50e5 SHA1 5b78308368519c3c93f14616e4df343b879c3980 SHA256 8f2788afdfd883363aa7c39ce7e806b78392307ca459bcb3b13f3a0da5cbfc7b
EBUILD sysprof-1.0.12.ebuild 1845 RMD160 27f6bdfbb56b9656fe6b1ca19796253fa4489cf5 SHA1 763862468be1fc7fc7653ade54ef083a1e2ce096 SHA256 5da32802aecacbc235f55f4b8bdeb480dbd8130d71ccdff9b37bc99221a03773
-MISC ChangeLog 2615 RMD160 e708063cf2027ef7bdb1b3c695fd3b71e1429293 SHA1 ec3e81a7b1e0349a5c46f5934eed2f9959d7dedc SHA256 96aa39d5319e40e086c9cda160a1388d19aff94db7a96ccaae9545bde3860a5c
+MISC ChangeLog 2845 RMD160 05a020b0a67b798bb9c483e945e9a385eb012501 SHA1 0cef115b1f60c2926a08e5a070ae6bb200831945 SHA256 4d060f4544e388e4384c4ebabb35362987e4a21dd42dc9fb5e018635efaf2acf
MISC metadata.xml 527 RMD160 3343e7162447afe6dbb9b7cf1f51eb779d86e431 SHA1 562a3deb40e4828ff412f3ee08ab40b99413e45d SHA256 22a19afd665c828ae34fcc7f424f1e07e6b087b10290c5c8209b9013f0bc761b
diff --git a/dev-util/sysprof/sysprof-1.0.12-r1.ebuild b/dev-util/sysprof/sysprof-1.0.12-r1.ebuild
new file mode 100644
index 000000000000..68b8b4fc295b
--- /dev/null
+++ b/dev-util/sysprof/sysprof-1.0.12-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.12-r1.ebuild,v 1.1 2009/05/27 11:02:05 remi Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ x11-libs/pango
+ >=gnome-base/libglade-2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ MODULE_NAMES="sysprof-module(misc:${S}/module)"
+ CONFIG_CHECK="PROFILING"
+ PROFILING_ERROR="You need to enable Profiling support in your kernel. \
+For this you need to enable 'Profiling support' under 'Instrumentation Support'. \
+It is marked CONFIG_PROFILING in the config file"
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ econf --disable-kernel-module || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry sysprof Sysprof sysprof-icon
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo "On many systems, especially amd64, it is typical that with a modern"
+ einfo "toolchain -fomit-frame-pointer for gcc is the default, because"
+ einfo "debugging is still possible thanks to gcc4/gdb location list feature."
+ einfo "However sysprof is not able to construct call trees if frame pointers"
+ einfo "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ einfo "for the libraries and applications involved in the profiling. That"
+ einfo "means a CPU register is used for the frame pointer instead of other"
+ einfo "purposes, which means a very minimal performance loss when there is"
+ einfo "register pressure."
+}