summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-11-19 21:28:57 +0000
committerZack Welch <zwelch@gentoo.org>2002-11-19 21:28:57 +0000
commit0267cba5ff483820dd7e3693f22c4f2f5957e2fd (patch)
tree668356c35de9f0a4a8bc4530905419cfa413ea9a /dev-util
parentthe rest of the kde 3.1 ebuilds (diff)
downloadhistorical-0267cba5ff483820dd7e3693f22c4f2f5957e2fd.tar.gz
historical-0267cba5ff483820dd7e3693f22c4f2f5957e2fd.tar.bz2
historical-0267cba5ff483820dd7e3693f22c4f2f5957e2fd.zip
add bitkeeper-3.0-r1 ebuild
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bitkeeper/ChangeLog9
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
index 70ff5b2b6efc..d3d6718224b4 100644
--- a/dev-util/bitkeeper/ChangeLog
+++ b/dev-util/bitkeeper/ChangeLog
@@ -1,6 +1,11 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-util/bitkeeper
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.2 2002/11/17 01:33:24 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.3 2002/11/19 21:28:57 zwelch Exp $
+
+*bitkeeper-3.0-r1 (18 Nov 2002)
+
+ 18 Nov 2002; Evan Powers <powers.161@osu.edu> :
+ Fixed permissions and ownership of installed files
*bitkeeper-3.0 (15 Nov 2002)
diff --git a/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild
new file mode 100644
index 000000000000..63dabeaa054f
--- /dev/null
+++ b/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild,v 1.1 2002/11/19 21:28:57 zwelch Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="BitKeeper is a scalable configuration management system."
+SRC_URI=""
+HOMEPAGE="http://www.bitkeeper.com"
+DEPEND=">=virtual/glibc-2.2
+ >=dev-lang/tcl-8.3.3
+ X? ( >=dev-lang/tk-8.3.3 )"
+
+SLOT="0"
+LICENSE="BKL"
+KEYWORDS="x86 ppc sparc alpha"
+
+# I'm not sure what the official way to do this is...
+[ -n "`use x86`" ] && A="bk-3.0-x86-glibc22-linux.bin"
+[ -n "`use ppc`" ] && A="bk-3.0-powerpc-glibc21-linux.bin"
+[ -n "`use sparc`" ] && A="bk-3.0-sparc-glibc21-linux.bin"
+[ -n "`use alpha`" ] && A="bk-3.0-alpha-glibc21-linux.bin"
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${A} ] ; then
+ einfo "****************************************************************************"
+ einfo "* Perform the following steps to install this package:"
+ einfo "* - Sign up at ${HOMEPAGE}"
+ einfo "* - Check your mail and visit the download location"
+ einfo "* - Download ${A} and place it in ${DISTDIR}"
+ einfo "* - emerge this package again"
+ einfo "****************************************************************************"
+ die "Follow the above instructions, please"
+ fi
+}
+
+src_unpack() {
+ mkdir ${S}
+ cp ${DISTDIR}/${A} ${S}/${A}
+ chmod 755 ${S}/${A}
+ echo 'none' | ${S}/${A} > ${S}/output 2>/dev/null
+ installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" ${S}/output`
+ archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" ${S}/output`
+ mv $installer ${S}/installer
+ mv $archive ${S}/archive
+}
+
+src_install () {
+ mkdir -p ${D}/opt ${D}/etc/env.d
+ cd ${D}/opt && tar -xzpf ${S}/archive
+ mv ${D}/opt/bitkeeper ${D}/opt/${P}
+ chown -R root:root ${D}/opt/${P}
+ chmod -R u+w,go-w ${D}/opt/${P}
+ cat <<EOF >${D}/etc/env.d/10bitkeeper
+# Generated by ${P}.ebuild
+PATH=/opt/${P}
+ROOTPATH=/opt/${P}
+MANPATH=/opt/${P}/man
+EOF
+}
+
+pkg_postinst () {
+ einfo "Run 'bk regressions' to verify the installation. (Recommended)"
+}