summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-22 20:05:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-22 20:05:20 +0000
commite074301ceb77ae93a494bc41b4ca5c0469f2110d (patch)
treeed0120b7c6d6c9ecefaf956ed0b8f776d9ce1040 /dev-util
parentAdd patch to fix some bugs thanks to Butchie <butchie@free.fr> in bug 148566 (diff)
downloadhistorical-e074301ceb77ae93a494bc41b4ca5c0469f2110d.tar.gz
historical-e074301ceb77ae93a494bc41b4ca5c0469f2110d.tar.bz2
historical-e074301ceb77ae93a494bc41b4ca5c0469f2110d.zip
Version bump to fix a severe upstream bug.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bouml/ChangeLog8
-rw-r--r--dev-util/bouml/bouml-2.17.1.ebuild55
-rw-r--r--dev-util/bouml/files/digest-bouml-2.17.13
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index ea5423f8df74..63d5a2ad3f38 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.4 2006/09/18 19:58:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.5 2006/09/22 20:05:20 flameeyes Exp $
+
+*bouml-2.17.1 (22 Sep 2006)
+
+ 22 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> -bouml-2.16.ebuild,
+ -bouml-2.17.ebuild, +bouml-2.17.1.ebuild:
+ Version bump to fix a severe upstream bug.
18 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> bouml-2.17.ebuild:
Fix building on Gentoo/FreeBSD and add ~x86-fbsd keyword.
diff --git a/dev-util/bouml/bouml-2.17.1.ebuild b/dev-util/bouml/bouml-2.17.1.ebuild
new file mode 100644
index 000000000000..5e0fea29971e
--- /dev/null
+++ b/dev-util/bouml/bouml-2.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.17.1.ebuild,v 1.1 2006/09/22 20:05:20 flameeyes Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e '/^MAKE/d' "${S}/Makefile"
+
+ find "${S}" -name '*.pro' -print0 | xargs -0 sed -i -e '/CONFIG/s:qt:qt thread:g'
+}
+
+src_compile() {
+ cd "${S}"
+ local sourcedirs=$(find . -name '*.pro' -not -name 'gpro.pro' -exec dirname {} \;)
+
+ for dir in ${sourcedirs}; do
+ pushd "${dir}"
+ "${QTDIR}/bin/qmake" QMAKE="${QTDIR}/bin/qmake"
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+ popd
+ done
+}
+
+src_install() {
+ # The provided wrapper is bogus, just install it in temporary directory and then remove it
+ emake BOUML_LIB="${D}/usr/$(get_libdir)/bouml" BOUML_DIR="${T}" install
+
+ # We fake the PATH change with LD_LIBRARY_PATH change, to follow the original wrapper
+ make_wrapper bouml "/usr/$(get_libdir)/bouml/bouml" . "/usr/$(get_libdir)/bouml"
+ sed -i -e 's:LD_LIBRARY_PATH:PATH:g' "${D}/usr/bin/bouml"
+
+ make_desktop_entry bouml "BOUML" bouml
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.17.1 b/dev-util/bouml/files/digest-bouml-2.17.1
new file mode 100644
index 000000000000..82fb45b67875
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.17.1
@@ -0,0 +1,3 @@
+MD5 1815d7fcf3ee32e051e67373d5b12a34 bouml_2.17.1.tar.gz 2734443
+RMD160 47c0bb94dfc6b7ab83c8aca276c16ad6d72ee545 bouml_2.17.1.tar.gz 2734443
+SHA256 9042ede98da40c10d4e73cce85488c29e252f4ac00f415bea1cc626328e50c13 bouml_2.17.1.tar.gz 2734443