summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2010-03-05 02:18:28 +0000
committerJonathan Callen <jcallen@gentoo.org>2010-03-05 02:18:28 +0000
commitb1b9c9d667f59176183ccae7779358c06f490956 (patch)
tree17bce32aea9e472714e9bc5e54c98bcfdf0ae743 /dev-vcs/qct/qct-1.7.ebuild
parentVersion bump (diff)
downloadhistorical-b1b9c9d667f59176183ccae7779358c06f490956.tar.gz
historical-b1b9c9d667f59176183ccae7779358c06f490956.tar.bz2
historical-b1b9c9d667f59176183ccae7779358c06f490956.zip
Move from dev-util/qct to dev-vcs/qct
Package-Manager: portage--svn/cvs/Linux i686
Diffstat (limited to 'dev-vcs/qct/qct-1.7.ebuild')
-rw-r--r--dev-vcs/qct/qct-1.7.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-vcs/qct/qct-1.7.ebuild b/dev-vcs/qct/qct-1.7.ebuild
new file mode 100644
index 000000000000..c1e0dc78c85b
--- /dev/null
+++ b/dev-vcs/qct/qct-1.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qct/qct-1.7.ebuild,v 1.1 2010/03/05 02:18:28 abcd Exp $
+
+EAPI="2"
+NEED_PYTHON="2.4"
+inherit distutils
+
+DESCRIPTION="PyQt based commit tool for many VCSs"
+HOMEPAGE="http://qct.sourceforge.net/"
+SRC_URI="http://qct.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar cvs mercurial monotone subversion"
+
+DEPEND="app-text/asciidoc
+ app-text/xmlto
+ dev-python/PyQt4
+ bazaar? ( dev-util/bzr )
+ cvs? ( dev-util/cvs )
+ mercurial? ( dev-util/mercurial )
+ monotone? ( dev-util/monotone )
+ subversion? ( dev-util/subversion )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ rm qctlib/vcs/p4.py
+
+ # support for git requires cogito which isn't in portage
+ rm qctlib/vcs/git.py
+ rm qctlib/vcs/cg.py
+
+ use bazaar || rm qctlib/vcs/bzr.py
+ use cvs || rm qctlib/vcs/cvs.py
+ use mercurial || rm qctlib/vcs/hg.py
+ use monotone || rm qctlib/vcs/mtn.py
+ use subversion || rm qctlib/vcs/svn.py
+}
+
+src_install() {
+ distutils_src_install
+
+ # needed for $PYVER
+ distutils_python_version
+
+ # manpage and html docs are built using asciidoc
+ make -C doc man html || die
+ doman doc/qct.1 || die
+ dohtml doc/qct.1.html || die
+
+ if use bazaar; then
+ insinto "$(python_get_sitedir)/bzrlib/plugins" || die
+ doins plugins/qctBzrPlugin.py || die
+ fi
+
+ if use mercurial; then
+ insinto "$(python_get_sitedir)/hgext" || die
+ doins hgext/qct.py || die
+ insinto /etc/mercurial/hgrc.d || die
+ doins "${FILESDIR}/qct.rc" || die
+ fi
+}