summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-02 20:18:11 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-02 20:18:11 +0000
commit68347940b4738e19b5e883848a442cda0b159198 (patch)
treeaff5daeb18b7b1160d35fd7f6c2ccba90c05c652 /eclass/toolchain.eclass
parentBackport fix from 0.16.5. Bug #440976 (diff)
downloadhistorical-68347940b4738e19b5e883848a442cda0b159198.tar.gz
historical-68347940b4738e19b5e883848a442cda0b159198.tar.bz2
historical-68347940b4738e19b5e883848a442cda0b159198.zip
do not sed libstdc++ python dir with gcc-4.7+ since the issue has been fixed in those versions
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index f85a18fbaea2..da2806122ff6 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.552 2012/10/01 05:03:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.553 2012/11/02 20:18:11 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -711,7 +711,7 @@ toolchain_src_unpack() {
# install the libstdc++ python into the right location
# http://gcc.gnu.org/PR51368
- if tc_version_is_at_least 4.5 ; then
+ if tc_version_is_at_least 4.5 && ! tc_version_is_at_least 4.7 ; then
sed -i \
'/^pythondir =/s:=.*:= $(datadir)/python:' \
"${S}"/libstdc++-v3/python/Makefile.in || die