summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-29 06:41:15 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-29 06:41:15 +0000
commitaf7966f9030243efbfc92c5040482a47e3cb3e96 (patch)
tree5d0994eb6fe5c0cde8d773e682653a57ea64b8a1 /eclass/toolchain.eclass
parentAdd a subslot. (diff)
downloadhistorical-af7966f9030243efbfc92c5040482a47e3cb3e96.tar.gz
historical-af7966f9030243efbfc92c5040482a47e3cb3e96.tar.bz2
historical-af7966f9030243efbfc92c5040482a47e3cb3e96.zip
only mess with libffi stuff with gcc-3.1+
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 6a7d3bad0bac..56fcd09cb700 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.563 2012/12/29 06:08:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.564 2012/12/29 06:41:15 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -779,8 +779,10 @@ toolchain_src_unpack() {
fi
# Prevent libffi from being installed
- sed -i -e 's/\(install.*:\) install-.*recursive/\1/' "${S}"/libffi/Makefile.in
- sed -i -e 's/\(install-data-am:\).*/\1/' "${S}"/libffi/include/Makefile.in
+ if tc_version_is_at_least 3.1 ; then
+ sed -i -e 's/\(install.*:\) install-.*recursive/\1/' "${S}"/libffi/Makefile.in || die
+ sed -i -e 's/\(install-data-am:\).*/\1/' "${S}"/libffi/include/Makefile.in || die
+ fi
# Fixup libtool to correctly generate .la files with portage
cd "${S}"