summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-15 19:26:13 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-15 19:26:13 +0000
commit248eba59e410a5b0821c0c0d87d1dd6598f4ac41 (patch)
tree0f34ec58d1cba158565aeee269664209ffd696af /games-action/phobiaii
parentInitial import, ebuild by Ben de Groot, submitted in bug #146738. (diff)
downloadhistorical-248eba59e410a5b0821c0c0d87d1dd6598f4ac41.tar.gz
historical-248eba59e410a5b0821c0c0d87d1dd6598f4ac41.tar.bz2
historical-248eba59e410a5b0821c0c0d87d1dd6598f4ac41.zip
Change hard-coded /opt to GAMES_PREFIX_OPT.
Package-Manager: portage-2.1.1
Diffstat (limited to 'games-action/phobiaii')
-rw-r--r--games-action/phobiaii/ChangeLog8
-rw-r--r--games-action/phobiaii/files/phobiaII2
-rw-r--r--games-action/phobiaii/phobiaii-1.1.ebuild6
3 files changed, 12 insertions, 4 deletions
diff --git a/games-action/phobiaii/ChangeLog b/games-action/phobiaii/ChangeLog
index 87e27b8d9d8c..8acb90c809b3 100644
--- a/games-action/phobiaii/ChangeLog
+++ b/games-action/phobiaii/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/phobiaii
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/ChangeLog,v 1.6 2005/08/11 11:58:02 r3pek Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/ChangeLog,v 1.7 2006/09/15 19:26:13 wolf31o2 Exp $
+
+ 15 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org> files/phobiaII,
+ phobiaii-1.1.ebuild:
+ Change hard-coded /opt to GAMES_PREFIX_OPT.
11 Aug 2005; Carlos Silva <r3pek@gentoo.org> phobiaii-1.1.ebuild:
marked ~amd64. closes bug #102056
diff --git a/games-action/phobiaii/files/phobiaII b/games-action/phobiaii/files/phobiaII
index 6150b8757e2f..146ad9118023 100644
--- a/games-action/phobiaii/files/phobiaII
+++ b/games-action/phobiaii/files/phobiaII
@@ -1,3 +1,3 @@
#!/bin/sh
-cd /opt/phobiaii
+cd GAMES_PREFIX_OPT/phobiaii
exec ./linuxphobia "$@"
diff --git a/games-action/phobiaii/phobiaii-1.1.ebuild b/games-action/phobiaii/phobiaii-1.1.ebuild
index 0a976daeeef7..9c1e9826eeea 100644
--- a/games-action/phobiaii/phobiaii-1.1.ebuild
+++ b/games-action/phobiaii/phobiaii-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/phobiaii-1.1.ebuild,v 1.9 2006/06/23 05:15:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/phobiaii/phobiaii-1.1.ebuild,v 1.10 2006/09/15 19:26:13 wolf31o2 Exp $
inherit games
@@ -31,6 +31,10 @@ src_install() {
dodir "${GAMES_PREFIX_OPT}"/${PN}
mv * "${D}/${GAMES_PREFIX_OPT}"/${PN}/
+ dosed ":GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" \
+ ${GAMES_BINDIR}/phobiaII || die "sed"
+
+
dogamesbin "${FILESDIR}"/phobiaII || die "dogamesbin failed"
prepgamesdirs
}