summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-09-29 20:21:46 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-09-29 20:21:46 +0000
commit99555da5eb4ceabebc40e348a17c8cc6b5a9e9d2 (patch)
tree16e9200dcbd61c56548e39cf252bd1c54a2c12b4 /games-arcade/opensonic/files
parentmedia-gfx/gimp: Remove vulnerable 2.6.12-r{2,4} (diff)
downloadhistorical-99555da5eb4ceabebc40e348a17c8cc6b5a9e9d2.tar.gz
historical-99555da5eb4ceabebc40e348a17c8cc6b5a9e9d2.tar.bz2
historical-99555da5eb4ceabebc40e348a17c8cc6b5a9e9d2.zip
fix compilation for --as-needed
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'games-arcade/opensonic/files')
-rw-r--r--games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch b/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch
index 684685100d86..b4db7644bc9d 100644
--- a/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch
+++ b/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch
@@ -6,6 +6,7 @@ use allegro-config
remove "-O2" from pre-defined CFLAGS
make paths modifiable
add rules for icon, desktop-file and game-wrapper
+fix compilation for as-needed
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -39,16 +40,19 @@ add rules for icon, desktop-file and game-wrapper
IF(NOT ALLEGRO_UNIX_VERSION STREQUAL ALLEGRO_RECOMMENDED_VERSION)
MESSAGE("\nWARNING: your Allegro version is ${ALLEGRO_UNIX_VERSION}. The recommended version is ${ALLEGRO_RECOMMENDED_VERSION}.\n ${GAME_NAME} may not compile properly!.\n")
ENDIF(NOT ALLEGRO_UNIX_VERSION STREQUAL ALLEGRO_RECOMMENDED_VERSION)
-@@ -251,7 +250,7 @@
+@@ -249,9 +248,8 @@
+ IF(UNIX)
+ SET(GAME_SRCS ${GAME_SRCS} src/misc/iconlin.c)
ADD_EXECUTABLE(${GAME_UNIXNAME} ${GAME_SRCS})
- SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES LINK_FLAGS ${ALLEGRO_UNIX_LIBS})
- TARGET_LINK_LIBRARIES(${GAME_UNIXNAME} m logg vorbisfile vorbis ogg jpgalleg z png loadpng)
+- SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES LINK_FLAGS ${ALLEGRO_UNIX_LIBS})
+- TARGET_LINK_LIBRARIES(${GAME_UNIXNAME} m logg vorbisfile vorbis ogg jpgalleg z png loadpng)
- SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES COMPILE_FLAGS "-Wall -O2 ${CFLAGS} ${CFLAGS_EXTRA}")
++ TARGET_LINK_LIBRARIES(${GAME_UNIXNAME} m logg vorbisfile vorbis ogg jpgalleg z png loadpng ${ALLEGRO_UNIX_LIBS})
+ SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES COMPILE_FLAGS "-Wall")
ENDIF(UNIX)
-@@ -407,19 +406,43 @@
+@@ -407,19 +405,43 @@
SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES PROJECT_NAME "${GAME_NAME}")