summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-02-21 20:51:12 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-02-21 20:51:12 +0000
commit78bdf1a47be4e77c4b8eb950fb8ac9c15891033a (patch)
tree16e0561c23615bf23e86a8a92e04012d2d68b72b /games-arcade/performous/files
parentmarked x86 per bug 403405 (diff)
downloadhistorical-78bdf1a47be4e77c4b8eb950fb8ac9c15891033a.tar.gz
historical-78bdf1a47be4e77c4b8eb950fb8ac9c15891033a.tar.bz2
historical-78bdf1a47be4e77c4b8eb950fb8ac9c15891033a.zip
Version bump to 0.6.1 and rename from ultrastar-ng to performous. Bug #245452
Package-Manager: portage-2.1.10.48/cvs/Linux i686
Diffstat (limited to 'games-arcade/performous/files')
-rw-r--r--games-arcade/performous/files/performous-0.6.1-ffmpeg.patch13
-rw-r--r--games-arcade/performous/files/performous-0.6.1-gentoo.patch29
-rw-r--r--games-arcade/performous/files/performous-0.6.1-libpng.patch11
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch b/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
new file mode 100644
index 000000000000..38adb751d3b1
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
@@ -0,0 +1,13 @@
+--- game/ffmpeg.cc.old 2012-02-19 09:01:01.086108323 +0100
++++ game/ffmpeg.cc 2012-02-19 09:02:27.157984673 +0100
+@@ -60,8 +60,8 @@
+ for (unsigned int i=0; i<pFormatCtx->nb_streams; i++) {
+ AVCodecContext* cc = pFormatCtx->streams[i]->codec;
+ cc->workaround_bugs = FF_BUG_AUTODETECT;
+- if (videoStream == -1 && cc->codec_type==CODEC_TYPE_VIDEO) videoStream = i;
+- if (audioStream == -1 && cc->codec_type==CODEC_TYPE_AUDIO) audioStream = i;
++ if (videoStream == -1 && cc->codec_type==AVMEDIA_TYPE_VIDEO) videoStream = i;
++ if (audioStream == -1 && cc->codec_type==AVMEDIA_TYPE_AUDIO) audioStream = i;
+ }
+ if (videoStream == -1 && decodeVideo) throw std::runtime_error("No video stream found");
+ if (audioStream == -1 && decodeAudio) throw std::runtime_error("No audio stream found");
diff --git a/games-arcade/performous/files/performous-0.6.1-gentoo.patch b/games-arcade/performous/files/performous-0.6.1-gentoo.patch
new file mode 100644
index 000000000000..e9a6fe316b95
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-gentoo.patch
@@ -0,0 +1,29 @@
+--- game/CMakeLists.txt.old 2012-02-20 13:19:35.219635192 +0100
++++ game/CMakeLists.txt 2012-02-20 13:20:06.025469808 +0100
+@@ -149,5 +149,5 @@
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/config.cmake.hh" "${CMAKE_CURRENT_BINARY_DIR}/config.hh" @ONLY)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+
+-install(TARGETS performous DESTINATION bin)
++install(TARGETS performous DESTINATION @GENTOO_BINDIR@)
+
+--- game/fs.cc.old 2012-02-20 20:09:48.171892171 +0100
++++ game/fs.cc 2012-02-20 20:16:14.197400202 +0100
+@@ -195,6 +195,7 @@
+ if (root) config_list.push_back(std::string(root) + "/" SHARED_DATA_DIR + configFile.string());
+ fs::path exec = plugin::execname();
+ if (!exec.empty()) config_list.push_back(exec.parent_path().string() + "/../" SHARED_DATA_DIR + configFile.string());
++ config_list.push_back(SHARED_DATA_DIR + configFile.string());
+ ConfigList::const_iterator it = std::find_if(config_list.begin(), config_list.end(), static_cast<bool(&)(fs::path const&)>(fs::exists));
+ if (it == config_list.end()) {
+ throw std::runtime_error("Could not find default config file " + configFile.string());
+--- game/fs.cc.old 2012-02-20 20:49:35.610728056 +0100
++++ game/fs.cc 2012-02-20 20:57:03.117084432 +0100
+@@ -167,6 +167,7 @@
+
+ // Adding relative path from executable
+ dirs.push_back(plugin::execname().parent_path().parent_path() / shareDir);
++ dirs.push_back(shareDir);
+ #ifndef _WIN32
+ // Adding XDG_DATA_DIRS
+ {
diff --git a/games-arcade/performous/files/performous-0.6.1-libpng.patch b/games-arcade/performous/files/performous-0.6.1-libpng.patch
new file mode 100644
index 000000000000..2633e77c0fbb
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-libpng.patch
@@ -0,0 +1,11 @@
+--- game/image.hh.old 2012-02-19 09:20:09.215987761 +0100
++++ game/image.hh 2012-02-19 09:20:50.418077218 +0100
+@@ -26,7 +26,7 @@
+ }
+ void loadPNG_internal(png_structp pngPtr, png_infop infoPtr, std::ifstream& file, std::vector<unsigned char>& image, std::vector<png_bytep>& rows, unsigned& w, unsigned& h) {
+ if (setjmp(png_jmpbuf(pngPtr))) throw std::runtime_error("Reading PNG failed");
+- png_set_read_fn(pngPtr,(voidp)&file, readPngHelper);
++ png_set_read_fn(pngPtr,(png_voidp)&file, readPngHelper);
+ png_read_info(pngPtr, infoPtr);
+ png_set_expand(pngPtr); // Expand everything to RGB(A)
+ png_set_strip_16(pngPtr); // Strip everything down to 8 bit/component