summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-05 21:47:20 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-05 21:47:20 +0000
commitc5b175d0d1fe60610ae5f98498ea31aea9fa42e3 (patch)
tree1ac10806b78c1d1e3ee0a7cad32ea8691b275e01 /games-arcade/performous/files
parentStable on amd64 wrt bug #406853 (diff)
downloadhistorical-c5b175d0d1fe60610ae5f98498ea31aea9fa42e3.tar.gz
historical-c5b175d0d1fe60610ae5f98498ea31aea9fa42e3.tar.bz2
historical-c5b175d0d1fe60610ae5f98498ea31aea9fa42e3.zip
Clean up ebuild.
Package-Manager: portage-2.2.0_alpha86/cvs/Linux x86_64
Diffstat (limited to 'games-arcade/performous/files')
-rw-r--r--games-arcade/performous/files/performous-0.6.1-linguas.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/games-arcade/performous/files/performous-0.6.1-linguas.patch b/games-arcade/performous/files/performous-0.6.1-linguas.patch
new file mode 100644
index 000000000000..21836766d878
--- /dev/null
+++ b/games-arcade/performous/files/performous-0.6.1-linguas.patch
@@ -0,0 +1,15 @@
+--- lang/CMakeLists.txt
++++ lang/CMakeLists.txt
+@@ -7,5 +7,11 @@
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
+ add_custom_command(OUTPUT ${mofile} COMMAND ${Msgfmt_BIN} -v "${pofile}" -o ${mofile} MAIN_DEPENDENCY ${pofile} COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target(locale_${language} ALL DEPENDS ${mofile}) # Make sure the mofiles are always built
+- install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)