summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commit4449c749e4d0a531f4dffcd6bd11772e59ecbf81 (patch)
tree47ac23a46562d1736503b9b2447f81b34199c04e /games-emulation/ps2emu-padxwin
parentNew package - rename. (diff)
downloadhistorical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.gz
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.bz2
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/ps2emu-padxwin')
-rw-r--r--games-emulation/ps2emu-padxwin/ChangeLog8
-rw-r--r--games-emulation/ps2emu-padxwin/Manifest4
-rw-r--r--games-emulation/ps2emu-padxwin/files/0.3-makefile.patch11
-rw-r--r--games-emulation/ps2emu-padxwin/files/digest-ps2emu-padxwin-0.31
-rw-r--r--games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.3.ebuild37
5 files changed, 61 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-padxwin/ChangeLog b/games-emulation/ps2emu-padxwin/ChangeLog
new file mode 100644
index 000000000000..4589559bee0a
--- /dev/null
+++ b/games-emulation/ps2emu-padxwin/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/ps2emu-padxwin
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*ps2emu-padxwin-0.3 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-emulation/ps2emu-padxwin/Manifest b/games-emulation/ps2emu-padxwin/Manifest
new file mode 100644
index 000000000000..11a4f08bc5bb
--- /dev/null
+++ b/games-emulation/ps2emu-padxwin/Manifest
@@ -0,0 +1,4 @@
+MD5 4c7deb53ac8737032938c4d8b4f10c40 files/0.3-makefile.patch 392
+MD5 adfc89c49540671897beb6b3d717f864 files/digest-ps2emu-padxwin-0.3 58
+MD5 82732d95096083772e125a5df02800e2 ChangeLog 368
+MD5 d2d71f3bb8ef52a76000a0c423558c85 ps2emu-padxwin-0.3.ebuild 789
diff --git a/games-emulation/ps2emu-padxwin/files/0.3-makefile.patch b/games-emulation/ps2emu-padxwin/files/0.3-makefile.patch
new file mode 100644
index 000000000000..e819216106ae
--- /dev/null
+++ b/games-emulation/ps2emu-padxwin/files/0.3-makefile.patch
@@ -0,0 +1,11 @@
+--- Src/Makefile.orig 2003-08-14 21:09:59.330722776 -0400
++++ Src/Makefile 2003-08-14 21:10:08.885270264 -0400
+@@ -2,7 +2,7 @@
+ VERSION = 0
+ BUILD = 3
+ PLUGIN = libPADxwin-${VERSION}.${BUILD}.so
+-CFLAGS = -fPIC -Wall -O2 -fomit-frame-pointer -D__LINUX__
++CFLAGS = -fPIC -Wall $(OPTFLAGS) -D__LINUX__
+ OBJECTS = PAD.o Conf.o
+ OBJECTS+= interface.o support.o
+ LIBS = $(shell gtk-config --libs)
diff --git a/games-emulation/ps2emu-padxwin/files/digest-ps2emu-padxwin-0.3 b/games-emulation/ps2emu-padxwin/files/digest-ps2emu-padxwin-0.3
new file mode 100644
index 000000000000..253206c46afe
--- /dev/null
+++ b/games-emulation/ps2emu-padxwin/files/digest-ps2emu-padxwin-0.3
@@ -0,0 +1 @@
+MD5 12d166dbe8e84c4db459ab335ceb564b PADxwin-0.3.gz 21351
diff --git a/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.3.ebuild b/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.3.ebuild
new file mode 100644
index 000000000000..aa9ca97a0b5d
--- /dev/null
+++ b/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.3.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 PAD plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.4release/PADxwin-${PV}.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/PADxwin
+
+src_unpack() {
+ unpack ${A}
+ tar -xf PADxwin-${PV} || die "unpacking tar"
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd Src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd Src
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ doexe lib*
+ prepgamesdirs
+}