summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-17 08:04:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-17 08:04:15 +0000
commitf0f4ded8189d34892e8297b5ee65cf4954098705 (patch)
tree34c4cbb4501c818f05ed6c21b53b1df5f88aa28e /games-engines
parentremove old (diff)
downloadhistorical-f0f4ded8189d34892e8297b5ee65cf4954098705.tar.gz
historical-f0f4ded8189d34892e8297b5ee65cf4954098705.tar.bz2
historical-f0f4ded8189d34892e8297b5ee65cf4954098705.zip
version bump
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog8
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild40
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/scummvm-1.0.0.ebuild82
4 files changed, 136 insertions, 2 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index 5ffd3ee7fba4..706ae7df4267 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.28 2009/11/14 20:47:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.29 2009/11/17 08:04:15 mr_bones_ Exp $
+
+*scummvm-tools-1.0.0 (17 Nov 2009)
+
+ 17 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-tools-1.0.0.ebuild:
+ version bump
14 Nov 2009; Markus Meier <maekke@gentoo.org>
scummvm-tools-1.0.0_rc1.ebuild:
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild
new file mode 100644
index 000000000000..db983a8645cc
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild,v 1.1 2009/11/17 08:04:15 mr_bones_ Exp $
+
+EAPI=2
+WX_GTK_VER=2.8
+inherit toolchain-funcs wxwidgets games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/flac
+ media-libs/libvorbis
+ x11-libs/wxGTK:2.8"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ rm -f *.bat
+ sed -ri \
+ -e '/^(CC|CXX)\b/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ local f
+ for f in $(find . -type f -perm +1 -print); do
+ newgamesbin $f ${PN}-${f##*/} || die "newgamesbin $f failed"
+ done
+ dodoc README TODO
+ prepgamesdirs
+}
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index a68962a9aad2..3a30929c1732 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.80 2009/11/14 20:46:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.81 2009/11/17 08:02:51 mr_bones_ Exp $
+
+*scummvm-1.0.0 (17 Nov 2009)
+
+ 17 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-1.0.0.ebuild:
+ version bump
14 Nov 2009; Markus Meier <maekke@gentoo.org> scummvm-1.0.0_rc1.ebuild:
amd64/x86 stable, bug #292946
diff --git a/games-engines/scummvm/scummvm-1.0.0.ebuild b/games-engines/scummvm/scummvm-1.0.0.ebuild
new file mode 100644
index 000000000000..9ec3388b7a27
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.0.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.0.0.ebuild,v 1.1 2009/11/17 08:02:51 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
+ >media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ Makefile.common \
+ || die "sed failed"
+ sed -i \
+ -e '/INSTALL.*doc\//d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk \
+ || die "sed failed"
+}
+
+src_configure() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ # let the engine find its data files in the right place (bug #178116)
+ myconf="${myconf} --datadir=${GAMES_DATADIR}"
+
+ ( use vorbis || use ogg ) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis"
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}" \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ doicon icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}