summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-08 05:56:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-08 05:56:20 +0000
commit38317014290f9e97585cf9514b78a34b904f8937 (patch)
tree7385703a04ff29a717f689536600dd34a57ba58f /games-fps
parentfix md5sums in data files #37419 (diff)
downloadhistorical-38317014290f9e97585cf9514b78a34b904f8937.tar.gz
historical-38317014290f9e97585cf9514b78a34b904f8937.tar.bz2
historical-38317014290f9e97585cf9514b78a34b904f8937.zip
fix install paths #35952
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog7
-rw-r--r--games-fps/quake2-icculus/files/0.15-Makefile-noopts.patch19
-rw-r--r--games-fps/quake2-icculus/files/0.15-gentoo-path.patch55
-rw-r--r--games-fps/quake2-icculus/files/digest-quake2-icculus-0.15-r1 (renamed from games-fps/quake2-icculus/files/digest-quake2-icculus-0.15)0
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild (renamed from games-fps/quake2-icculus/quake2-icculus-0.15.ebuild)40
5 files changed, 96 insertions, 25 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index 164664d9d727..f3c78bdb11b2 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.3 2003/12/27 19:45:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.4 2004/01/08 05:56:20 vapier Exp $
+
+*quake2-icculus-0.15-r1 (08 Jan 2004)
+
+ 08 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Fix installed paths #35952.
*quake2-relnev-0.15 (29 Jun 2003)
diff --git a/games-fps/quake2-icculus/files/0.15-Makefile-noopts.patch b/games-fps/quake2-icculus/files/0.15-Makefile-noopts.patch
new file mode 100644
index 000000000000..0f4c4f3dea24
--- /dev/null
+++ b/games-fps/quake2-icculus/files/0.15-Makefile-noopts.patch
@@ -0,0 +1,19 @@
+--- Makefile.orig 2003-01-23 17:26:45.000000000 -0500
++++ Makefile 2003-01-23 17:26:54.000000000 -0500
+@@ -82,12 +82,12 @@
+ endif
+
+ ifeq ($(ARCH),i386)
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -O2 -ffast-math -funroll-loops -malign-loops=2 \
+- -malign-jumps=2 -malign-functions=2 -g
++RELEASE_CFLAGS=-ffast-math -funroll-loops $(BASE_CFLAGS)
++# -falign-jumps=2 -falign-functions=2 -g
+ # compiler bugs with gcc 2.96 and 3.0.1 can cause bad builds with heavy opts.
+ #RELEASE_CFLAGS=$(BASE_CFLAGS) -O6 -m486 -ffast-math -funroll-loops \
+-# -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
+-# -malign-jumps=2 -malign-functions=2
++# -fomit-frame-pointer -fexpensive-optimizations -falign-loops=2 \
++# -falign-jumps=2 -falign-functions=2
+ endif
+
+ VERSION=3.21+rCVS
diff --git a/games-fps/quake2-icculus/files/0.15-gentoo-path.patch b/games-fps/quake2-icculus/files/0.15-gentoo-path.patch
new file mode 100644
index 000000000000..7e1b8a97f9b2
--- /dev/null
+++ b/games-fps/quake2-icculus/files/0.15-gentoo-path.patch
@@ -0,0 +1,55 @@
+--- src/qcommon/files.c.orig 2004-01-02 01:55:47.219787792 -0500
++++ src/qcommon/files.c 2004-01-02 01:55:55.622510384 -0500
+@@ -0,0 +1 @@
++#include "../linux/gentoo-libdir.h"
+@@ -60,6 +60,7 @@
+
+ char fs_gamedir[MAX_OSPATH];
+ cvar_t *fs_basedir;
++cvar_t *fs_libdir;
+ cvar_t *fs_cddir;
+ cvar_t *fs_gamedirvar;
+
+@@ -898,7 +899,8 @@
+ // basedir <path>
+ // allows the game to run from outside the data tree
+ //
+- fs_basedir = Cvar_Get ("basedir", ".", CVAR_NOSET);
++ fs_basedir = Cvar_Get ("basedir", "GENTOO_DATADIR", CVAR_NOSET);
++ fs_libdir = Cvar_Get ("libdir", GENTOO_LIBDIR, CVAR_NOSET);
+
+ //
+ // cddir <path>
+@@ -913,6 +915,7 @@
+ // add baseq2 to search path
+ //
+ FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
++ FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_libdir->string) );
+
+ //
+ // then add a '.quake2/baseq2' directory in home directory by default
+--- src/linux/vid_so.c.orig 2004-01-02 10:37:46.527355832 -0500
++++ src/linux/vid_so.c 2004-01-02 10:39:23.890554376 -0500
+@@ -0,0 +1 @@
++#include "../linux/gentoo-libdir.h"
+@@ -231,13 +232,17 @@
+ //regain root
+ seteuid(saved_euid);
+
+- path = Cvar_Get ("basedir", ".", CVAR_NOSET)->string;
++ path = Cvar_Get ("libdir", GENTOO_LIBDIR, CVAR_NOSET)->string;
+
+ snprintf (fn, MAX_OSPATH, "%s/%s", path, name );
+
+ if (stat(fn, &st) == -1) {
+- Com_Printf( "LoadLibrary(\"%s\") failed: %s\n", name, strerror(errno));
+- return false;
++ path = Cvar_Get ("basedir", ".", CVAR_NOSET)->string;
++ snprintf (fn, MAX_OSPATH, "%s/%s", path, name );
++ if (stat(fn, &st) == -1) {
++ Com_Printf( "LoadLibrary(\"%s\") failed: %s\n", name, strerror(errno));
++ return false;
++ }
+ }
+
+ // permission checking
diff --git a/games-fps/quake2-icculus/files/digest-quake2-icculus-0.15 b/games-fps/quake2-icculus/files/digest-quake2-icculus-0.15-r1
index 3f8d9c69a534..3f8d9c69a534 100644
--- a/games-fps/quake2-icculus/files/digest-quake2-icculus-0.15
+++ b/games-fps/quake2-icculus/files/digest-quake2-icculus-0.15-r1
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.15.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild
index 3f78aa769638..39e45f69ebae 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.15.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.15.ebuild,v 1.3 2003/12/30 04:01:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild,v 1.1 2004/01/08 05:56:20 vapier Exp $
inherit games eutils gcc
@@ -16,7 +16,7 @@ SRC_URI="http://icculus.org/quake2/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc"
+KEYWORDS="x86 ppc sparc alpha"
IUSE="svga X sdl aalib opengl noqmax rogue xatrix"
# default to X11 if svga/X/sdl/aalib are not in USE
@@ -33,8 +33,11 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${MY_P}.tar.gz
cd ${S}
- [ `gcc-major-version` == 3 ] && epatch ${FILESDIR}/${PV}-Makefile-gcc3.patch
+ epatch ${FILESDIR}/${PV}-Makefile-noopts.patch
epatch ${FILESDIR}/${PV}-Makefile-optflags.patch
+ epatch ${FILESDIR}/${PV}-gentoo-path.patch
+ sed -i "s:GENTOO_DATADIR:${GAMES_DATADIR}/quake2-data:" src/qcommon/files.c
+
ln -s `which echo` ${T}/more
for g in `use rogue` `use xatrix` ; do
mkdir -p ${S}/src/${g}
@@ -63,6 +66,9 @@ src_compile() {
# rogue fails to build
for BUILD_QMAX in YES NO ; do
[ `use noqmax` ] && [ "${BUILD_QMAX}" == "YES" ] && continue
+ [ "${BUILD_QMAX}" == "YES" ] \
+ && echo "#define GENTOO_LIBDIR \"${GAMES_LIBDIR}/${PN}-qmax\"" > src/linux/gentoo-libdir.h \
+ || echo "#define GENTOO_LIBDIR \"${GAMES_LIBDIR}/${PN}\"" > src/linux/gentoo-libdir.h
make clean || die "cleaning failed"
make build_release \
BUILD_SDLQUAKE2=`yesno sdl` \
@@ -105,32 +111,18 @@ src_install() {
# regular q2 files
dodir ${q2dir}
cp -rf my-rel-NO/* ${D}/${q2dir}/
-# strip my-rel-NO/{*,*/*}
-
- into ${GAMES_PREFIX}
- newbin ${FILESDIR}/quake2.start quake2
- newbin ${FILESDIR}/q2ded.start q2ded
- if [ `use sdl` ] ; then
- newbin ${FILESDIR}/sdlquake2.start sdlquake2
- dosed "s:GENTOO_LIBDIR:${q2dir}:" ${GAMES_BINDIR}/sdlquake2
- fi
- dosed "s:GENTOO_LIBDIR:${q2dir}:" ${GAMES_BINDIR}/quake2
- dosed "s:GENTOO_LIBDIR:${q2dir}:" ${GAMES_BINDIR}/q2ded
+ dogamesbin ${D}/${q2dir}/{quake2,q2ded}
+ rm ${D}/${q2dir}/{quake2,q2ded}
+ use sdl && dogamesbin ${D}/${q2dir}/sdlquake2 && rm ${D}/${q2dir}/sdlquake2
# q2max files
if [ ! `use noqmax` ] ; then
dodir ${q2maxdir}
cp -rf my-rel-YES/* ${D}/${q2maxdir}/
-
- into ${GAMES_PREFIX}
- newbin ${FILESDIR}/quake2.start quake2-qmax
- newbin ${FILESDIR}/q2ded.start q2ded-qmax
- if [ `use sdl` ] ; then
- newbin ${FILESDIR}/sdlquake2.start sdlquake2-qmax
- dosed "s:GENTOO_LIBDIR:${q2maxdir}:" ${GAMES_BINDIR}/sdlquake2-qmax
- fi
- dosed "s:GENTOO_LIBDIR:${q2maxdir}:" ${GAMES_BINDIR}/quake2-qmax
- dosed "s:GENTOO_LIBDIR:${q2maxdir}:" ${GAMES_BINDIR}/q2ded-qmax
+ newgamesbin ${D}/${q2maxdir}/quake2 quake2-qmax
+ newgamesbin ${D}/${q2maxdir}/q2ded q2ded-qmax
+ rm ${D}/${q2maxdir}/{quake2,q2ded}
+ use sdl && newgamesbin ${D}/${q2maxdir}/sdlquake2 sdlquake2-qmax && rm ${D}/${q2maxdir}/sdlquake2
insinto ${q2maxdir}/baseq2
doins ${DISTDIR}/maxpak.pak